Druckbare Version des Themas
Hier klicken um das Thema im Original Format zu betrachten.
HTPC Forum > Installation/Konfiguration > Gen2VDR V6 auf Scaelo-Evi Shutdown/Wakeup Probleme


Geschrieben von: T5000 am Sonntag, 07.Mai 2017, 20:46 Uhr
Hallo,

ich habe ein Scaleo-EVI mit CineS2 und nutze die Activy 3x0 Fernbedienung.

ich war gezwungen meinen VDR neu zu installieren und habe die Möglichkeit genutzt um das System von Gen2VDR V3 auf V6 Update 5 upzudaten.
Dabei hab ich das Setup mit Kernel-Option 3 installiert, weil die 1 nicht ging.
Weiterhin hab ich die Partionen erhalten umd die Videos nicht zu verlieren.

Das System funktioniert soweit, jedoch schaff ich es nicht den Standby Modus einzurichten.

Nach dem Artikel hier: http://www.vdr-wiki.de/wiki/index.php/Scaleo_E/Evi/Activy5xx#Das_Display

soll es ja mit NVRAM funktionieren.

Ich hab auch ein dvb_update.sh laufen lassen, kann die Meldungen aber nicht so recht deuten ob nun wirklich die aktuellsten DVB Treiber verwendet werden.

Aktuell habe ich die nvram-wakeup.conf aus dem Artikel (ich hab die gleiche BIOS Version) nach /_config/install/ als nvram-wakeup.conf.SCALEO kopiert.
und im g2v_setup.sh

│ │ Shutdown-Variante < Halt > │ │
│ │ Wakeupreserve in Sekunden [ 300 ] │ │
│ │ Wakeup-Methode < NVRAM > │ │
│ │ NVRAM Board - BIOS [ SCALEO ] │ │

eingestellt

früher funktionierte mit der Scaleo-EVI ein Suspend to Disk, also er hat den Ram auf Platte gespeichert und das System in S3(?) schlafen gelegt, dabei hat der Rechner ein paar mal gepiept und die Front LED blinkte.
Beim Druck auf Power, kam der Rechner aus dem S3 wieder hoch und nach ein paar Sekunden war das TV Bild da.

Aktuell geht er mit Shutdown-Variante < STR > in Standby und die LED blinkt gelb, beim einschalten ist dann aber kein Bild da, also der TV zeigt an "kein HDMI Signal" , nach ca. 1min macht der Rechner ein Reset und fährt normal hoch. Ein zeitgesteuertes Wakeup habe ich noch nicht getestet.

Mit Shutdown-Variante < halt > fährt der Rechner komplett runter und schaltet aus und beim einschalten normal wieder hoch.

Die Varianten STD1 und STD2 verhalten sich wie bei HALT. Ich hab da irgendwie das Gefühl, das das System gar nicht erst versucht den Raminhalt auf Platte abzulegen.

Die Logs sind mit angehangen. Vieleicht kann ja ein Wissender sich da was draus nehmen.

Danke schon mal im vorraus .... smile.gif

Gruss Thomas

Geschrieben von: HelAu am Montag, 08.Mai 2017, 08:40 Uhr
Hallo,

Für suspend to disk fehlt ein Boot parameter.
Füge in der /etc/lilo.conf so ca in Zeile 21 an die append Zeile
resume=/dev/sda3
an:

CODE
...
image  = /boot/bzImage-act
label  = Gen2VDR
root = /dev/sda1
vga    = normal
append = "rootfstype=ext4 video=uvesafb:off HOME=/root resume=/dev/sda3"
...

und starte danach
lilo

Dann könnte STD gehen. Bei STR siehts so aus, als ob Deine Grafikkarte bze der 340er Treiber dabei nicht mitmacht.

Geschrieben von: T5000 am Montag, 08.Mai 2017, 16:58 Uhr
Hallo Helmut,
Danke für deinen Input,

die liloconf sieht jetzt so aus:

CODE


image  = /boot/bzImage-act
label  = Gen2VDR
root = /dev/sda2
vga    = normal
append = "rootfstype=ext4 video=uvesafb:off HOME=/root resume=/dev/sda3"
#append = "rootfstype=ext4 video=uvesafb:1920x1080-24 HOME=/root"
#append = "noapic noisapnp  splash=silent,theme:vdr quiet CONSOLE=/dev/tty1 fbcon=scrollback:128K  video=uvesafb:off"
#append = "noapic noisapnp  video=uvesafb:off pci=nomsi"
#append = "init=/sbin/bootchartd noapic pci=nomsi"
#append = "pci=nomsi"
#initrd = /boot/fbsplash-g2v-800x600


leider funktioniert STD1 oder STD2 trotzdem nicht, einzige Änderung ist jetzt, das der VDR beim einschalten/aufwachen normal hochfährt, aber der VDR nicht korrekt startet und sich mit einem Reboot verabschiedet.

Beim nächsten hochfahren ist wieder alles OK.

Geschrieben von: T5000 am Montag, 08.Mai 2017, 18:45 Uhr
noch ne Frage,
besteht die Möglichkeit wieder einen älteren nvidia Treiber einzubinden?
Da natürlich auch die Frage: Wie geht das?

Gruss Thomas

Geschrieben von: HelAu am Montag, 08.Mai 2017, 19:42 Uhr
Beim STD überlebt wohl der ddbridge Treiber nicht.
Kannst Du mal versuchen ob es ohne das Ganze drumherum funktioniert:
CODE
stp vdr g2vgui
echo disk > /sys/power/state
# dann wieder einschalten
stt vdr g2vgui

Geschrieben von: T5000 am Montag, 08.Mai 2017, 19:55 Uhr
hm,

also einzeln funktioniert der STD soweit, das ich beim wiedereinschalten sehe, das er ein Image lädt und dann auch per sssh (Netzwerk) wieder erreichbar ist. ein stt vdr geht auch soweit, das die Menüs da sind, aber kein Empfang da ist. also ich kann die Sender auswählen, das OSD erscheint, aber das Bild bleibt schwarz.

sad.gif

Geschrieben von: T5000 am Dienstag, 09.Mai 2017, 19:37 Uhr
hab die Kiste nochmal neu installiert mit der Boot Option 2

da soll er doch eigentlich den Kernel 3.9 verwenden?

Bei mir ist aber weiterhin der Kernel 4.9.8 installiert sad.gif


Geschrieben von: HelAu am Mittwoch, 10.Mai 2017, 08:18 Uhr
Mach mal:
CODE
cd /tmp
wget http://www.gen2vdr.org/files/hib.tgz
cp /_config/bin/hibernate.sh /_config/bin/hibernate.sh.org
tar -C / -xf hib.tgz

und versuchs mit dem STD nochmal.
Installiert wird übrigens immer der aktuelle kernel, nur zum Booten der Installation kann man nen anderen wählen
P.S. Wegen des hibernate Problems darfst Du ein Ticket aufmachen smile.gif

Geschrieben von: T5000 am Mittwoch, 10.Mai 2017, 17:39 Uhr
wir kommen der Sache näher smile.gif

Aufwecken aus dem STD funktioniert soweit das der VDR läuft.
Auch ein umschalten mit der Tastatur funktioniert.

Was nicht geht ist die Fernbedienung ( bei mir muss der lircd auf /dev/lirc1 horchen)
auch das Netzwerk funktioniert nicht mehr. Kein Ping kein SSH.

Zeitgesteuert hab ich noch nicht getestet.

Logs lad ich dann mal noch hoch.

Gruss Thomas

so nun noch die Logs:

Geschrieben von: globber am Donnerstag, 11.Mai 2017, 09:35 Uhr
Moin,

ich habe ebenfalls die Scaleo Evi und habe seinerzeit auch den angesprochenen Artikel geschrieben. Seit längerer Zeit benutze ich aber NVRAM nicht mehr, weil der Default über ACPI bei mir schon seit Längerem funtkioniert.

Mit der Default Wakeup Methode habe ich keinerlei Wakeup Probleme

Regards
Globber

Geschrieben von: HelAu am Donnerstag, 11.Mai 2017, 21:56 Uhr
Zum einen, falls Du nicht mehr als den hdmi für Sound benötigst, solltest Du für alsa nur den hdmi Ausgang konfigurieren.
Dazu genuegt eine /etc/asound.conf mit dem Inhalt:
CODE
pcm.!default {
 type hw
 card 1
 device 3
}


Und zwecks dem startup, hast Du eine
/etc/conf.d/myhibernate.conf
und falls ja was steht da drinne ?

Geschrieben von: T5000 am Freitag, 12.Mai 2017, 10:19 Uhr
So, die asound.conf hab ich angepasst, jedoch benötige ich dort

card 1 / device 7

eine /etc/conf.d/myhibernate.conf gibt bei mir leider nicht.... blink.gif

Gruss Thomas

Geschrieben von: HelAu am Freitag, 12.Mai 2017, 13:44 Uhr
Das passt schon ich hab Dir ne Mail geschickt ...

Geschrieben von: T5000 am Freitag, 12.Mai 2017, 13:50 Uhr
gibt gleich Feedback, teste grad

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)