Powered by Invision Power Board


  
 
Reply to this topicStart new topicStart Poll

> Frage zur Tonausgabe
nichtsistfrei
Geschrieben am: Samstag, 20.Februar 2010, 23:04 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 38
Mitgliedsnummer.: 12193
Mitglied seit: 2009-12-22



Ich weiß es gibt viele Threads dazu, aber ich habe jetzt ein komisches verhalten meines Tons.

Mainboard ist ein Asus M3N78. Fernseher per HDMI angeschlossen, Verstärker zusätzlich per SPDIF.
Im Adminmenü habe ich unter Ausgabe/Gui folgendes stehen:
Audio Ausgabe: alsa
Signal des AudioOut: SPDIF


Ich hatte verschiedene Einstellungen Probiert. Somit hatte ich mal Ton per HDMI und mal wieder Ton per SPDIF. Aber am Verstärker kam immer nur PCM Signal an und kein Dolby Digital.

Also habe ich es Probiert ob per HDMI Dolby Digital übertragen wird und meinen Verstärker (Yamaha 863RXV) per HDMI an den VDR angeschlossen.
VDR -> TV per HDMI = Ton am TV
VDR -> Verstärker -> TV alles per HDMI = kein Ton am Verstärker oder TV. Bild wurde übertragen. Kennt jemand das Verhalten?


Weil ich aber auch den Dolby Digitalton per SPDIF übertragen wollte, habe ich hier gesucht und einen Hinweis gefunden die /root/.xine/config zu editieren.
Gesagt getan und den Eintrag

audio.output.speaker_arrangement:Pass Through

gesetzt.


Bei Filmen mit Digitalton, bekomme ich den jetzt auch am Verstärker per SPDIF ausgegeben. So wie es sein soll zeigt der Verstärker Digital und kein PCM an.

Das große aber:
Es werden nur Dolby Digital Streams per SPDIF übertragen. Filme ohne Digitalspur bleiben Stumm.
Weiterhin ist es am Fernseher genau umgedreht. Stelle ich auf Digital kommt der Ton nicht über HDMI an den Fernseher. Stelle ich auf eine Analoge Tonspur kommt der Ton per HDMI am Fernseher an?

Meine Traumvorstellung wären beide Signale an HDMI und SPDIF gleichzeitig. Dazu habe ich hier aber nichts genaues gefunden?

Das M3N78 EM haben doch viele im Einsatz. Bestimmt auch in meiner Konstellation. Digitalton und Analogton per SPDIF und HDMI. Kann mir jemand seine Konfiguration verraten ?

VG
Dirk
Email Poster
Top
kds70
Geschrieben am: Sonntag, 21.Februar 2010, 03:36 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 429
Mitgliedsnummer.: 10954
Mitglied seit: 2009-07-26



Habe zwar ne andere Config mit Soundblaster Live! 5.1 am Laufen aber das Problem kenne ich.

Analog Ton über SPDIF bekomme ich nur, wenn ich im alsamixer den "IEC958 O" mute / ausschalte.
Email PosterICQ
Top
nussa
Geschrieben am: Sonntag, 21.Februar 2010, 08:50 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 45
Mitgliedsnummer.: 1579
Mitglied seit: 2006-12-20



ich hab nicht die selbe hardware, aber bei mir hat

pcm.!default spdif

in der /root/.asoundrc geholfen.
damit werden alle pcm ausgaben an spdif ausgegeben.


angehängte Datei ( Anzahl der Downloads: 190 )
angehängte Datei  .asoundrc
Email Poster
Top
nichtsistfrei
Geschrieben am: Sonntag, 21.Februar 2010, 11:55 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 38
Mitgliedsnummer.: 12193
Mitglied seit: 2009-12-22



Hi,

die Datei .asoundrc habe ich gar nicht unter /root
Ich habe auch schon die /etc/asound.conf mit der /etc/asound.conf.m3n78em ersetzt. Ebenfalls keine Änderung. Bekomme über SPDIF nur DD Ton
Email Poster
Top
ee
Geschrieben am: Sonntag, 21.Februar 2010, 12:39 Uhr
Quote Post


Prinz
****

Gruppe: Supporter
Beiträge: 1116
Mitgliedsnummer.: 1340
Mitglied seit: 2006-05-22



Das hat mit dem Thema "Nur PCM, kein DolbyDigital" nichts zu tun.

Die ".asoundrc" hilft nur etwas wenn man überhaupt keinen Ton bekommt.

DolbyDigital-Ausgabe muss man in der Datei "/root/.xine/config" einschalten:

CODE
# Lautsprecherplazierung
# { Mono 1.0  Stereo 2.0  Headphones 2.0  Stereo 2.1  Surround 3.0  Surround 4.0  Surround 4.1  Surround 5.0  Surround 5.1  Surround 6.0  Surround 6.1  Surround 7.1  Pass Through }, default: 1
audio.output.speaker_arrangement:Pass Through


Gruß
ee
Email PosterICQ
Top
nussa
Geschrieben am: Sonntag, 21.Februar 2010, 14:00 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 45
Mitgliedsnummer.: 1579
Mitglied seit: 2006-12-20




zitat ee:
"Die ".asoundrc" hilft nur etwas wenn man überhaupt keinen Ton bekommt."

den "pass trough" parameter in der config hat er ja schon eingetragen.

sicher hift die datei was, sie sagt alsa pcm über spdif auszugeben, bei mir bewirkt sie genau das. habe ich die datei nicht im root bekomme ich auch kein pcm über spdif nur ac3.

zitat nichtsistfrei:
"Bei Filmen mit Digitalton, bekomme ich den jetzt auch am Verstärker per SPDIF ausgegeben. So wie es sein soll zeigt der Verstärker Digital und kein PCM an."

also genau sein problem.

nussa
Email Poster
Top
nichtsistfrei
Geschrieben am: Sonntag, 21.Februar 2010, 14:27 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 38
Mitgliedsnummer.: 12193
Mitglied seit: 2009-12-22



@nussa
Habe die Datei ach schon ins root gelegt, bringt leider keine Änderung. PCM Ton kommt nur per HDMI
Email Poster
Top
pdeg69
Geschrieben am: Montag, 15.März 2010, 13:59 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 81
Mitgliedsnummer.: 2789
Mitglied seit: 2007-09-29



nussa Posted: February 21, 2010 09:50 am

Danke schon. Worked for me with V3 Beta 5. 5.1 worked but no PCM. Now PCM also works. Thanks!!!

(V3 Beta 4 did work without this file)
Email Poster
Top
Thema wird von 1 Benutzer(n) gelesen (1 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic Options Reply to this topicStart new topicStart Poll