Powered by Invision Power Board


Seiten: (3) 1 [2] 3  ( Zum ersten neuen Beitrag
 
Reply to this topicStart new topicStart Poll

> Stand der Beta nach Update 4
 
Welchen Zustand hat die Beta bei Euch
Alles Bestens [ 1 ]  [4.00%]
Laeuft nach Aenderungen uebers admin Plugin [ 4 ]  [16.00%]
Laeuft nach manuellen Aenderungen [ 7 ]  [28.00%]
Laeuft mit Maengeln [ 12 ]  [48.00%]
Laeuft nicht [ 1 ]  [4.00%]
Stimmen Gesamt: 25
Gäste können nicht abstimmen, 'Die Registrierung dauert nur eine Minute 
HelAu
Erstellt am Mittwoch, 12.August 2009, 07:14 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 11074
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



Indem Du das VDR Gui beendest ( ueber Menu-> Befehle, oder mit der ESC Taste, oder einer Taste fuer switch_console.sh in der /etc/lircrc )
Email PosterUsers WebsiteICQAOLYahoo
Top
Nambo
Erstellt am Mittwoch, 12.August 2009, 11:00 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 128
Mitgliedsnummer.: 678
Mitglied seit: 2005-09-14



@HelAu danke hat sich erledigt
Email Poster
Top
hampit
Erstellt am Freitag, 14.August 2009, 08:03 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 391
Mitgliedsnummer.: 1325
Mitglied seit: 2006-05-06



Hi,

ich habe diesen komischen bildversatz(wie man das richtig nennt weiss ich noch nicht) entfernt bekommen.

Hab mir die edid.bin extrahiert und eine neue xorg.conf erstellt. Dann in diese xorg.conf einiges aus der von wbreu eingefügt.

siehe:

CODE
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (portage@vdr01)  Sa 6. Jun 13:29:08 CEST 2009

Section "ServerLayout"
   Identifier     "Layout0"
   Screen      0  "Screen0" 0 0
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
   FontPath        "/usr/lib/X11/fonts/misc/:unscaled"
   FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
   FontPath        "/usr/lib/X11/fonts/misc/"
   FontPath        "/usr/lib/X11/fonts/75dpi/"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

Section "Module"
  Load           "dbe"
  Load           "extmod"
  Load           "type1"
  Load           "freetype"
  Load           "glx"
EndSection

Section "ServerFlags"
   Option         "Xinerama" "0"
EndSection

Section "InputDevice"
   # generated from data in "/etc/conf.d/gpm"
   Identifier     "Mouse0"
   Driver         "mouse"
   Option         "Protocol"
   Option         "Device" "/dev/input/mice"
   Option         "Emulate3Buttons" "no"
   Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
   # generated from default
   Identifier     "Keyboard0"
   Driver         "kbd"
   Option         "XkbLayout" "de"
   Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
   # HorizSync source: edid, VertRefresh source: edid
   Identifier     "Monitor0"
   VendorName     "Unknown"
   ModelName      "SAMSUNG"
   HorizSync       26.0 - 81.0
   VertRefresh     24.0 - 75.0
#    Option         "DPMS"
EndSection

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   BoardName      "GeForce 8400 GS"
  Option         "UseEvents" "True"
  Option         "Overlay" "True"
  Option         "OverlayDefaultVisual" "True"
  Option         "NVAGP" "3"
  Option         "BackingStore" "True"
  Option         "TripleBuffer" "True"
  Option         "Coolbits" "1"
  Option         "XvmcUsesTextures" "True"
  Option         "ConnectToAcpid" "False"
  Option         "DamageEvents" "True"
  Option         "RenderAccel" "True"
  Option         "AddARGBGLXVisuals" "True"
  Option         "AddARGBVisuals" "True"
  Option         "AllowGLXWithComposite" "True"
  Option         "DisableGLXRootClipping" "True"
  Option         "UseEDIDFreqs" "False"
  Option         "UseEDIDDpi" "False"
  Option         "CustomEdid" "DFP-0:/etc/X11/edid.bin"
  Option         "ConnectedMonitor" "DFP-0"
  Option        "UseDisplayDevice" "DFP-0"
  Option         "ModeValidation" "DFP-0: AllowInterlacedModes, NoMaxSizeCheck, NoPredefinedModes, NoWidthAlignmentCheck, NoHorizSyncCheck, NoVertRefreshCheck, AllowNon60HzDFPModes, NoEdidMaxPClkCheck, NoDFPNativeResolutionCheck"
  Option         "ExactModeTimingsDVI" "True"
  Screen          0
EndSection

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   DefaultDepth    24
   Option         "TwinView" "0"
#    Option         "metamodes" "1920x1080_50i +0+0"
   Option         "TwinViewXineramaInfoOrder" "DFP-0"
   SubSection     "Display"
       Depth       24
Modes      "1920x1080@50" "1920x1080@60i" "1920x1080@60" "1920x1080@59.94i" "1920x1080@24" "1920x1080@50i" "1920x1080@59.94" "1920x1080@23.976" "1920x1080@25" "1920x1080@29.97" "1920x1080@30"
   EndSubSection
EndSection



Obwohl das Bild nun schon sehr gut ist...der LCD schaltet noch nicht auf 50Hz. Wie bekomme ich das nun noch hin? Die Umschaltung mit den nvidia-settings auf 50i geht nicht. Ohne Fehlermeldung beim speichern meldet der LCD 60Hz.

Email Poster
Top
jr!
Erstellt am Freitag, 14.August 2009, 08:41 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



gehst du über hdmi oder dvi an den lcd?

Frage: kann man die edid.bin auch auf der console extrahieren ? ic hab keine maus angeschlossen und auch keine zur verfügung :(
Email Poster
Top
hampit
Erstellt am Freitag, 14.August 2009, 08:49 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 391
Mitgliedsnummer.: 1325
Mitglied seit: 2006-05-06



Kenn nur diese möglichkeit um an die edid.bin zu kommen.

Die GraKa hat ne dvi. Mit Adapter gehts dann in den LCD per HDMI.

Email Poster
Top
jr!
Erstellt am Freitag, 14.August 2009, 09:16 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



poste mal die ausgabe von

CODE

DISPLAY=:0.0 xrand


wenn der X server läuft

greets jr
Email Poster
Top
wbreu
Erstellt am Freitag, 14.August 2009, 09:17 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 239
Mitgliedsnummer.: 1453
Mitglied seit: 2006-08-28



Moin hampit,

mit dem Bildversatz, war das bei dir so in der oberen Hälfte, das das Bild immer nachzieht, versetzt dargestellt wird, nach einer bestimmten Zeit?

Wenn ja ist das "Tearing" gewesen.

Das beseitigt du mit dem Abschalten von Composite in der xorg.conf.

Section "Extensions"
Option "Composite" "Disable"
EndSection

Um Auskunft zu bekommen, was dein Display kann, starte mal den X-Server mit der Option -logverbose 6.

Da steht dann alles drinnen, was das Display und die Graka betrifft.

Gruß
Wolfgang
Email PosterUsers Website
Top
jr!
Erstellt am Freitag, 14.August 2009, 09:19 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



ich glaube das der ientrag in seiner xorg.conf schon drinnne is :/
Email Poster
Top
wbreu
Erstellt am Freitag, 14.August 2009, 09:57 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 239
Mitgliedsnummer.: 1453
Mitglied seit: 2006-08-28



QUOTE (jr! @ Freitag, 14.August 2009, 09:19 Uhr)
ich glaube das der ientrag in seiner xorg.conf schon drinnne is :/

Hi,

darum gings ja nicht.

hampit hat sich gefragt, was das ist und wie das heißt?

Deshalb der Post von mir.

Gruß
Wolfgang
Email PosterUsers Website
Top
jr!
Erstellt am Freitag, 14.August 2009, 10:00 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



Nunja da dies aber schon in seiner Xorg.conf steht ist es unwahrscheinlich das es tearing ist was er versucht zu beschreiben.

greets jr
Email Poster
Top
hampit
Erstellt am Freitag, 14.August 2009, 10:35 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 391
Mitgliedsnummer.: 1325
Mitglied seit: 2006-05-06



QUOTE (jr! @ Freitag, 14.August 2009, 10:16 Uhr)
poste mal die ausgabe von

CODE

DISPLAY=:0.0 xrand


wenn der X server läuft

greets jr

CODE
vdr01 ~ # DISPLAY=:0.0 xrandr
Screen 0: minimum 640 x 350, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
  1920x1080      50.0*    51.0     52.0     53.0     54.0     55.0     56.0                                                   57.0
  1680x1050      58.0
  1440x900       59.0     60.0
  1400x1050      61.0     62.0
  1360x768       63.0
  1280x1024      64.0     65.0     66.0     67.0     68.0
  1280x960       69.0     70.0     71.0
  1280x800       72.0
  1280x720       73.0     74.0     75.0
  1152x864       76.0     77.0
  1024x768       78.0     79.0     80.0     81.0     82.0     83.0     84.0                                                   85.0
  832x624        86.0
  800x600        87.0     88.0     89.0     90.0     91.0     92.0     93.0                                                   94.0
  720x576        95.0
  720x480        96.0
  720x400        97.0
  640x480        98.0     99.0    100.0    101.0    102.0    103.0    104.0
  640x400       105.0
  640x350       106.0
vdr01 ~ #
Email Poster
Top
hampit
Erstellt am Freitag, 14.August 2009, 10:38 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 391
Mitgliedsnummer.: 1325
Mitglied seit: 2006-05-06



QUOTE (wbreu @ Freitag, 14.August 2009, 10:17 Uhr)
Moin hampit,

mit dem Bildversatz, war das bei dir so in der oberen Hälfte, das das Bild immer nachzieht, versetzt dargestellt wird, nach einer bestimmten Zeit?

Wenn ja ist das "Tearing" gewesen.

Das beseitigt du mit dem Abschalten von Composite in der xorg.conf.

Section "Extensions"
Option "Composite" "Disable"
EndSection

Um Auskunft zu bekommen, was dein Display kann, starte mal den X-Server mit der Option -logverbose 6.

Da steht dann alles drinnen, was das Display und die Graka betrifft.

Gruß
Wolfgang

Hallo Wolfgang, deine Beschreibung triffts genau. Hab ich auch so gemeint.

Der Eintrag ist auch in der originalen xorg.conf, aber wohl an der falschen stelle.

@wbreu
und ja danke, jetzt weiss ich was des "tearing" ist :D

edit:
den x-server starte ich später neu. der vdr ist bereits in betrieb und frau guckt ;)
Email Poster
Top
jr!
Erstellt am Freitag, 14.August 2009, 12:27 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



So nun zu deiner ersten frage mit den 60 50 hz problem, dein LCD läuft mit 50hz zumindest sendet der xserver dieses signal zu erkennen an der ausgabe bei xrand wo der kleine stern steht is deine wiederholfrequenz alle die dahinter stehen gibt es noch,
also bei deinem wahrscheinlich würde 1920x1080@60hz nicht funktionieren da bei 57 schluss ist.

kann natürlich sein intern trotzdem auf 60 hz schaltet, da kennich mich einfach zu wenig aus.

mit
CODE

DISPLAY=:0.0 xrand -r 1280x720 -r 75


würdest du auf 720p schalten (frag mich wieso dein lcd keine 60hz bei der auflösung macht ?!?)
mit xrand kann man auch bissl rumspielen die ergebnisse sieht man sofort ohne X jedes mal neu zu starten. xrand ändert auch nix an den configs was zu testen ganz gut ist.

greets jr
Email Poster
Top
wbreu
Erstellt am Freitag, 14.August 2009, 12:41 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 239
Mitgliedsnummer.: 1453
Mitglied seit: 2006-08-28



Hallo jr,

naja die Aussage die du da triffst ist falsch!

CODE

1920x1080      50.0*    51.0     52.0     53.0     54.0     55.0     56.0                                                   57.0


bedeutet, dass der X-Server hier insgesamt 8 Modes für 1920x1080 akzeptiert hat, das sind keinesfalls die Hz-Angaben.

Wenn jetzt Hampit die obigen Modes in der xorg.conf aktiviert hat, bedeutet das noch nicht, dass sie vom Display aktzepiert worden sind.

Deshalb auch die Frage nach dem log des X-Servers beim Start.

Der xrandr-Befehl schaltet immer die Modes um nicht nur die Hz.

50.0 bedeutet erster akzepierter Mode, 51.0 bedeutet zweiter akzepierter Mode, usw.

Umschalten zwischen den Modes eht mit xrandr -d :0 -s 1920x1080 -r 50 oder eben
xrandr -d :0 -s 1920x1080 -r 51, usw. oder andere Auflösung eben gleich der Syntax.

Mehr kann man erst sagen, wenn das log da ist.

Heißt das Tool in gen2vdr wirklich xrand ohne "r"?

Gruß
Wolfgang

Email PosterUsers Website
Top
jr!
Erstellt am Freitag, 14.August 2009, 13:05 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



nein es heisst xrandr.

Ich denke doch das das herzzahlen sind. was wäre das für ein irrsinn dem mode so abnormkomische zahlen zuzuweisen wenn sie nicht in beziehung mit den herz stehen würden?
und ja der schalter heisst wie bei mir beschrieben nicht -r für resolution sonder -s für size,
zum beispiel mit xrandr -s 1280x720 -r 60 krieg ich mein LCD in 720p modus.
bei mir ist die list die xrandr auswirft auch wesentlich kürzer und so modes wie 1650 werden bei mir gar nicht aufgeführt. ich gehe auch nativ mit hdmi an den LCD und nicht über einen Adapter.

QUOTE

Wenn jetzt Hampit die obigen Modes in der xorg.conf aktiviert hat, bedeutet das noch nicht, dass sie vom Display aktzepiert worden sind.

Hab ich ja gar nicht behauptet aber xrandr zeigt mit dem Stern an welcher mod aktiviert ist. Dabei spielt es sicherlich gar keine rolle was in der xorg.conf noch so drin steht. Die Ausgabe von xrandr sind natürlich meistens Daten direkt vom LCD und nicht aus der xorg.conf

greest jr

Email Poster
Top
hampit
Erstellt am Freitag, 14.August 2009, 13:10 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 391
Mitgliedsnummer.: 1325
Mitglied seit: 2006-05-06



Hi,

auch hier mit r am ende.

Hier mein logverbose:
CODE
vdr01 ~ # startx -logverbose 6
xauth:  creating new authority file /root/.serverauth.2967


X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-gentoo-r2 i686
Current Operating System: Linux vdr01 2.6.30-gentoo-r4 #2 SMP PREEMPT Fri Jul 31 11:08:34 CEST 2009 i686
Build Date: 19 July 2009  12:26:05PM

       Before reporting problems, check http://wiki.x.org
       to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
       (++) from command line, (!!) notice, (II) informational,
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 14 14:07:50 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "type1" (module does not exist, 0)
(EE) Failed to load module "freetype" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
Warning: Missing charsets in String to FontSet conversion
twm: warning: font for charset JISX0208.1983-0 is lacking.
twm: warning: font for charset KSC5601.1987-0 is lacking.
twm: warning: font for charset GB2312.1980-0 is lacking.
twm: warning: font for charset JISX0208.1983-0 is lacking.
twm: warning: font for charset KSC5601.1987-0 is lacking.
twm: warning: font for charset GB2312.1980-0 is lacking.
twm: warning: font for charset JISX0208.1983-0 is lacking.
twm: warning: font for charset KSC5601.1987-0 is lacking.
twm: warning: font for charset GB2312.1980-0 is lacking.
twm: warning: font for charset JISX0208.1983-0 is lacking.
twm: warning: font for charset KSC5601.1987-0 is lacking.
twm: warning: font for charset GB2312.1980-0 is lacking.
twm: warning: font for charset JISX0208.1983-0 is lacking.
twm: warning: font for charset KSC5601.1987-0 is lacking.
twm: warning: font for charset GB2312.1980-0 is lacking.
twm: warning: font for charset JISX0208.1983-0 is lacking.
twm: warning: font for charset KSC5601.1987-0 is lacking.
twm: warning: font for charset GB2312.1980-0 is lacking.



Email Poster
Top
wbreu
Erstellt am Freitag, 14.August 2009, 13:21 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 239
Mitgliedsnummer.: 1453
Mitglied seit: 2006-08-28



Hallo hampit,

der log ist nicht komplett oder der logverbose ist da falsch.

Schau mal bitte im Aufruf für X da sollte der Parameter dran.

@jr, ok dann sage ich mal nix mehr dazu, schau aber mal trotzdem ins log, was passiert, wenn du mit xrandr auf der Konsole arbeitest und du .... -r 50 oder ...-r 51 eingibst.

PS: Im Anhang mal ein älteres Log, wie das dann aussieht.

Gruß
Wolfgang

angehängte Datei ( Anzahl der Downloads: 97 )
angehängte Datei  Xorg.0.log
Email PosterUsers Website
Top
hampit
  Erstellt am Freitag, 14.August 2009, 13:48 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 391
Mitgliedsnummer.: 1325
Mitglied seit: 2006-05-06



Das kann ich noch bieten. Wobei sich beim beenden von vdr der X laut top sich mit 100% CPU-last rumwüstet?!
Beenden lässt sich X dann nur noch mit killall -9 X

Danach folgende konsolenein und -ausgaben:

CODE
vdr01 ~ # X -logverbose -6
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/vdr01:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-gentoo-r2 i686
Current Operating System: Linux vdr01 2.6.30-gentoo-r4 #2 SMP PREEMPT Fri Jul 31                                               11:08:34 CEST 2009 i686
Build Date: 19 July 2009  12:26:05PM

       Before reporting problems, check http://wiki.x.org
       to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
       (++) from command line, (!!) notice, (II) informational,
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 14 14:42:28 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "type1" (module does not exist, 0)
(EE) Failed to load module "freetype" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server



Ins log-file schreibt er nur dieses:


CODE
tail -f /var/log/Xorg.0.log
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-gentoo-r2 i686
Current Operating System: Linux vdr01 2.6.30-gentoo-r4 #2 SMP PREEMPT Fri Jul 31 11:08:34 CEST 2009 i686
Build Date: 19 July 2009  12:26:05PM

       Before reporting problems, check http://wiki.x.org
       to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
       (++) from command line, (!!) notice, (II) informational,
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.


In der Tat ein bischen wenig.
Email Poster
Top
jr!
Erstellt am Freitag, 14.August 2009, 14:10 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 157
Mitgliedsnummer.: 1657
Mitglied seit: 2007-01-30



PS: Grad nochmal geschaut schalter -r auf xrandr heisst Rate und es scheinen wohl die herz zahlen zu sein die damit gemeint sind.
Email Poster
Top
cdc42
Erstellt am Sonntag, 23.August 2009, 12:50 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 189
Mitgliedsnummer.: 1447
Mitglied seit: 2006-08-21



Ich habe leider immer ein sporadisches Ruckeln im Bild, sowohl bei SD als auch bei HD Sendern. Auf arte HD konnte ich gestern die schöne Konzertaufzeichnung durchgängig schauen, hier waren mal keine Ruckler. Aber der Ton setzte alle paar Minuten für ein paar Sekunden aus. Im Log gab es nichts zu sehen.

Die Buffer in der xine config habe ich auskomentiert und hochgesetzt.
composite ist auf disabled in der xorg.conf

Desweiteren ist das Lastproblem mit lircd leider noch vorhanden (mceusb2 mit USB Empfänger/transceiver)

Das System (Sig) taktet nicht runter.
Email Poster
Top
Thema wird von 0 Benutzer(n) gelesen (0 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic OptionsSeiten: (3) 1 [2] 3  Reply to this topicStart new topicStart Poll