Powered by Invision Power Board


Seiten: (2) [1] 2  ( Zum ersten neuen Beitrag
 
Reply to this topicStart new topicStart Poll

> Burn 0.2.2 geht nicht
zwick der agent
Geschrieben am: Donnerstag, 11.April 2013, 17:01 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 354
Mitgliedsnummer.: 12530
Mitglied seit: 2010-02-12



Ich versuche gerade eine Aufnahme zu brennen. Aber Burn bricht einfach ab. Was wird eigentlich alles für Burn benötigt und vor allem wo? Kann mir dabei jemand helfen?

Hier noch das Log...

angehängte Datei ( Anzahl der Downloads: 195 )
angehängte Datei  vdrburn_Bill_Cosby_Show.txt
Email Poster
Top
HelAu
Geschrieben am: Donnerstag, 11.April 2013, 17:41 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 11036
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



Hallo
Du solltest das aktuelle Burn aus dem git und das darin enthaltene Burnscript nehmen .. Du koenntest auch auf vdr-2.0 umsteigen, da ist das Burn dabei
Email PosterUsers WebsiteICQAOLYahoo
Top
zwick der agent
Geschrieben am: Donnerstag, 11.April 2013, 18:07 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 354
Mitgliedsnummer.: 12530
Mitglied seit: 2010-02-12



Ok ich muß jetzt erst mal noch was erledigen ;) Dann versuche ich mal die Git-Version. Ich habe aber folgenden Fehler im Log:

CODE
[author] STAT: Processing /tmp/vdr-burn.Bill_Cosby_Show.LgBZ8y/VDRSYNC.0/movie.mpg...
[demux] Multicolor OFF / switches 00000000
[demux] Loading libidctfast.so ... failed!!!
[demux]
[demux] java.lang.UnsatisfiedLinkError: no idctfast in java.library.path
[demux] Reading CLI Switches...
[demux] -> loading 2 (P)IDs...
[demux] Preparing GUI (if enabled)...
[demux] Check Commons-Net library access...
[demux] Stopped! An Error has occured...
[demux] java.lang.Exception:
[demux] commons-net library not accessible! see readme.txt [ii]
[demux] ensure the correct location/classpath, related to the executed .jar
[demux]
[demux]  at net.sourceforge.dvb.projectx.common.Start.main(Unknown Source)
[vdr] process demux (pid = 11790) exited gracefully (exit code 1)
[vdr] process "demux" exited
[vdr] ERROR: process author (pid = 11791) crashed (signal 15)


Grüße

Email Poster
Top
franky
Geschrieben am: Donnerstag, 11.April 2013, 19:31 Uhr
Quote Post


Prinz
****

Gruppe: Supporter
Beiträge: 1569
Mitgliedsnummer.: 1547
Mitglied seit: 2006-11-19



Hi,

weder das burn-0.2.0, das in vdr-2.0.0 dabei ist, noch ein Update auf burn-0.2.2 bringt was.
Auch das burnscript aus den aktuellen sourcen bringt erst mal nix.

Mittlerweile hab ich es bei mir am mit vdr-2.0.0 und burn-2.0.0 am Laufen.
1. Man braucht das aktuelle brunscript und dazu das neue Config-File.
2. Man muss ProjectX unter /opt neu installieren und dann das Config-File des burnscripts anpassen.

Dann läuft der Build-Prozess schon mal fast komplett durch.
Es gibt aber noch Abbrüche von mplex.
Da bin ich dann im VDR-Portal fündig geworden.
Man kann mplex, ein Programm der mjpegtools patchen damit die under-runs keine Abbrüche mehr verursachen.
Hat einige Zeit gedauert, bis ich diesen patch an stable Version der mjpegtools im portage angepasst hatte.

Jetzt konnte ich aber mjpegtools mit dem patch neu bauen und burn erstellt das iso ohne meckern.

Muss mal schauen, dass ich das Alles zusammen fasse und evtl. als HowTo poste.

Gruß
Klaus
Email Poster
Top
zwick der agent
Geschrieben am: Donnerstag, 11.April 2013, 19:47 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 354
Mitgliedsnummer.: 12530
Mitglied seit: 2010-02-12



Soo jetzt bin ich wieder zu Hause.....Au das wäre echt schon wenn Du uns ein Howto posten könntest. Ich wäre echt froh wenn das brennen wieder funktionieren würde ;)

Grüße

Email Poster
Top
zwick der agent
Geschrieben am: Freitag, 12.April 2013, 20:14 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 354
Mitgliedsnummer.: 12530
Mitglied seit: 2010-02-12



Ok ich habe jetzt mal ProjectX aus dem CVS geholt und gebaut. Dann Mjpegtools gepatched und neu gebaut. Burn läuft jetzt auch soweit los bis auf das hier:

CODE
[demux] 87 %
[demux] 90 %
[demux] 94 %
[demux] 98 %
[demux] 101 %-> skip sequence_end_code following GOP# 96 @ 56985960
[demux]
[demux] -> Video: fr-ct-1p-cg-og-dg -> 3279-0-96-96-0-0
[demux] -> Video length: 3279 frames @ 00:02:11.160
[demux] -> GOP summary: min. 20, max. 100 fields; contains interlaced frames
[demux] -> avg. nom. bitrate 3475813bps (min/max: 2324400/4294400)
[demux] -> set first sequenceheader bitrate to 4294400bps
[demux] ---> new File: /tmp/vdr-burn.Bill_Cosby_Show.el69qn/VDRSYNC.0/vdrsync.new.mpv
[demux]
[demux] +> Input File 3:  '/tmp/vdr-burn.Bill_Cosby_Show.sa7UQU/VDRSYNC.0/convert/00001.ts' (62.466.196 bytes)
[demux] -> Filetype is TS (generic PES Container)
[demux] !> filetype is not supported as a secondary file. check the file order/segmentation.
[demux]
[demux] +> Input File 4:  '/tmp/vdr-burn.Bill_Cosby_Show.sa7UQU/VDRSYNC.0/convert/00001_log.txt' (3.107 bytes)
[demux] -> Filetype is unknown
[demux] !> Filetype not supported !


Ich dachte die neue Version kann mit TS umgehen?

Hier noch das Log

angehängte Datei ( Anzahl der Downloads: 232 )
angehängte Datei  vdrburn_Bill_Cosby_Show.txt
Email Poster
Top
zwick der agent
Geschrieben am: Freitag, 12.April 2013, 22:56 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 354
Mitgliedsnummer.: 12530
Mitglied seit: 2010-02-12



Ok, hat sich erledigt. Burn geht nun. Es lag an der Aufnahme, habe gerade mal eine andere getestet und die wurde erfolgreich zum Iso erstellt. Ich teste die nächsten Tage ein wenig und gebe wieder bescheid.

Grüße

Email Poster
Top
NetWraith
Geschrieben am: Samstag, 13.April 2013, 21:36 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 480
Mitgliedsnummer.: 12782
Mitglied seit: 2010-03-20



Hi,

hatte auch das Problem, aber bei mir lag es am Aufruf von ProjectX.
Da ich regelmässig World-Updates mache, ist auch ProjectX aktuell:
CODE
vdr ~ # eix projectx
[I] media-video/projectx
    Available versions:  0.91.0.05 0.91.0.08 {X doc mmx source sse ELIBC="FreeBSD"}
    Installed versions:  0.91.0.08(11:04:35 PM 03/01/2013)(X mmx sse -doc -source ELIBC="-FreeBSD")
    Homepage:            http://project-x.sourceforge.net/
    Description:         Converts, splits and demuxes DVB and other MPEG recordings


Meine vdrburn-dvd.conf:
CODE
# settings for vdrburn-dvd.sh

# Java and Project X
#export JAVA_EXE=/usr/bin/java
export PROJECTX_JAR=/usr/share/projectx/lib/projectx.jar
export PROJECTX_CMD=/usr/bin/projectx_cli


Danach habe ich ab Zeile 95 in der vdrburn-dvd.sh folgendes geändert:
CODE
#  $IO_NICE $JAVA_EXE -Djava.awt.headless=true \
#    -jar $PROJECTX_JAR \
#    -ini $CONFIG_PATH/ProjectX.ini \
 $IO_NICE $PROJECTX_CMD -ini $CONFIG_PATH/ProjectX.ini \
   $TTXT_OPTS \
   $CUT -id $USED_TRACKS \
   -demux -out "$MPEG_DATA_PATH" -name vdrsync \
   $(ls "$MPEG_TMP_PATH/convert/"[0-9][0-9][0-9]*.*)


Somit wird ProjectX als Kommandozeilentool und nicht über den Java-Interpreter aufgerufen.

Viel Spaß beim Testen.

vy 55...
NetWraith
Email Poster
Top
NetWraith
Geschrieben am: Samstag, 13.April 2013, 22:46 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 480
Mitgliedsnummer.: 12782
Mitglied seit: 2010-03-20



BTW:
Was mir gerade mit burn-0.2.2 unter VDR 2.0.0 aufgefallen ist:
Ich kann nicht mehr auf mein via NFS gemountes NAS zu greifen.
In /video habe ich einen SymLink, der auf /mnt/NAS-Share zeigt.
Der wird beim AUswählen von Aufzeichnungen übersprungen. Unter VDR 1.7.32 konnte ich noch auf die Videos auf dem NAS zugreifen.

Unter Auzeichnungen und z.B auch YACOTO funzt der Link ohne Probleme.

Hat einer eine Idee? FireFly habe ich auch schon angetriggert.

mni tnx ...
NetWraith
Email Poster
Top
NetWraith
Geschrieben am: Sonntag, 14.April 2013, 13:36 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 480
Mitgliedsnummer.: 12782
Mitglied seit: 2010-03-20



QUOTE (NetWraith @ Samstag, 13.April 2013, 22:46 Uhr)
Was mir gerade mit burn-0.2.2 unter VDR 2.0.0 aufgefallen ist:
Ich kann nicht mehr auf mein via NFS gemountes NAS zu greifen.
In /video habe ich einen SymLink, der auf /mnt/NAS-Share zeigt.

GELÖST !

Habe gerade das Update auf VDR 2.0.1 gemacht und alles neugebaut.
Mein Problem ist damit Geschichte :D .

Schönen Sonntag ...
NetWraith
Email Poster
Top
kaminkehrer
Geschrieben am: Mittwoch, 17.April 2013, 12:30 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 1068
Mitgliedsnummer.: 300
Mitglied seit: 2004-02-08



Hallo,

@NetWraith: DANKE für die Anleitung.

Ich habe eine Frage und eine Bitte an Dich:

- Frage: Wo muss die "vdrburn-dvd.conf" hin, aktuell finde ich diese auf meinem System gar nicht.

- Bitte: kannst Du hierzu bitte eine Ticket öffnen, so dass das burn-plugin in einer der nächsten Versionen gefixt ist?

Grüße
kaminkehrer
Email Poster
Top
NetWraith
Geschrieben am: Mittwoch, 01.Mai 2013, 19:18 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 480
Mitgliedsnummer.: 12782
Mitglied seit: 2010-03-20



QUOTE (kaminkehrer @ Mittwoch, 17.April 2013, 12:30 Uhr)
- Frage: Wo muss die "vdrburn-dvd.conf" hin, aktuell finde ich diese auf meinem System gar nicht.

- Bitte: kannst Du hierzu bitte eine Ticket öffnen, so dass das burn-plugin in einer der nächsten Versionen gefixt ist?

Hi,

sorry, wenn ich heute erst antworte.
Die vdrburn-dvd.conf kommt nach /etc/vdr/plugins/burn. Das steht aber auch in der README vom Plugin ;).

Ein Ticket werde ich nicht auf machen, da dieses Problem nicht jeden trifft und normalerweise auch mit Java funktionieren sollte. Warum es bei Gen2VDR auf diese weise nicht geht, weiß ich im Moment nicht und habe auch zur Zeit keine Zeit, mich damit zu beschäftigen. Sorry.

Die Frage wäre auch, wer dafür zuständig wäre - FrieFly als Autor des Plugins oder Helmut wegen der Distri.
Ich persönlich neige zu keinem von beiden.

Wenn ich mal wieder mehr Zeit habe, schreibe ich ein HowTo in die passende Rubrik :).

vy 73 ...
NetWraith
Email Poster
Top
Kickaha
Geschrieben am: Dienstag, 07.Mai 2013, 07:32 Uhr
Quote Post


Professional
****

Gruppe: Professionals
Beiträge: 350
Mitgliedsnummer.: 2030
Mitglied seit: 2007-05-25



Hallo,

bei mir funktioniert das Burn Plugin auch leider noch nicht richtig.

VDR 2.0.1
Burn-Plugin 0.2.2
projectx 0.91.0.08
vdrburn-dvd.conf (von NetWraith) in /etc/vdr/plugins/burn
vdrburn-dvd.sh (von NetWraith) in /etc/vdr/plugins/burn

Im Makefile "TMPDIR ?= /video" angepasst wegen der Meldung über zuwenig Plattenplatz.

In den Burn Plugin Einstellungen kann ich jedoch als Ziel leider nichts ändern. Voreingestellt ist DVD Brennen. Ich will aber nur ein Iso erstellen. Vermutlich schlägt der Auftrag deswegen auch fehl?!

CODE
May 07 08:21:11 [vdr] [13174] connect from 192.168.229.16, port 50249 - accepted
May 07 08:21:11 [vdr] [13174] remote control LIRC - keys known
May 07 08:21:11 [vdr] [13174] remote control KBD - keys known
May 07 08:21:11 [vdr] [14061] [control] gateway thread started (pid=13134)
May 07 08:21:12 [vdr] [14062] KBD remote control thread started (pid=13134, tid=14062, prio=high)
May 07 08:21:13 [vdr] [14063] EnigmaNG effects thread started (pid=13134, tid=14063, prio=high)
May 07 08:21:20 [vdr] [13134] OSD size changed to 720x576 @ 1.06667
May 07 08:21:24 [vdr] [13134] burn: scanning recording "/video/Bisha/%Shaun_Of_The_Dead/2013-04-28.01.54.5-0.rec"
May 07 08:21:24 [vdr] [13134] loading /video/Bisha/%Shaun_Of_The_Dead/2013-04-28.01.54.5-0.rec//marks
May 07 08:21:24 [vdr] [13134] burn: marks available, skipping 10 seconds from first mark
May 07 08:21:24 [vdr] [13134] burn: scanning ts positions: 1/5317768-1/8231392
May 07 08:21:24 [vdr] [13134] burn: PID found: Vpid=0x2, Vtype=0x{2}
May 07 08:21:24 [vdr] [13134] burn: PID found: Apid0=0x80
May 07 08:21:24 [vdr] [13134] burn: language code for stream 00000080 (deu) is 'de'
May 07 08:21:24 [vdr] [13134] burn: found audio stream 8000c0
May 07 08:21:24 [vdr] [13134] burn: streamtype = mpeg1, layer 2, 192 kBit/s, stereo
May 07 08:21:24 [vdr] [13134] burn: found video stream a600e0
May 07 08:21:24 [vdr] [13134] burn: aspect = 16:9, 25 frames/s, bitrate = 15 MBits/s
May 07 08:21:24 [vdr] [13134] burn: PID 0x00a6 has 3220728702 packets
May 07 08:21:24 [vdr] [13134] burn: PID 0x0080 has 48 packets
May 07 08:21:24 [vdr] [13134] burn: language code for stream 00000080 (deu) is 'de'
May 07 08:21:24 [vdr] [13134] burn: movie size: 2877891968 (cut: 2877882944)
May 07 08:21:24 [vdr] [13134] burn: movie length: 1:29:53 (cut: 1:29:53)
May 07 08:21:31 [vdr] [13134] burn: setting fixed storemode to burn
               - Last output repeated 2 times -
May 07 08:21:49 [vdr] [13173] burn: manager is starting first job
May 07 08:21:49 [vdr] [13173] burn: writing detail log to /video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/dvd.log
May 07 08:21:49 [vdr] [14094] burn: subprocess watcher thread started (pid=13134, tid=14094, prio=high)
May 07 08:21:49 [vdr] [14094] burn: starting sh -c 'vdrburn-dvd.sh render' (pid = 14095)
May 07 08:21:49 [vdr] [14095] burn: MENU_ASPECT=16:9
May 07 08:21:49 [vdr] [14095] burn: MENU_BACKGROUND=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/menu-bg-0.png
May 07 08:21:49 [vdr] [14095] burn: MENU_M2V=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/menu-background.m2v
May 07 08:21:49 [vdr] [14095] burn: MENU_MPEG=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/menu-bg-0.mpg
May 07 08:21:49 [vdr] [14095] burn: MENU_SOUNDTRACK=/etc/vdr/plugins/burn/menu-silence.mp2
May 07 08:21:49 [vdr] [14095] burn: MENU_XML=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/menu-0.xml
May 07 08:21:49 [vdr] [14094] burn: process render (pid = 14095) exited gracefully (exit code 0)
May 07 08:21:50 [vdr] [14094] burn: starting sh -c 'vdrburn-dvd.sh render' (pid = 14102)
May 07 08:21:50 [vdr] [14102] burn: MENU_ASPECT=16:9
May 07 08:21:50 [vdr] [14102] burn: MENU_BACKGROUND=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0/menu-bg-0.png
May 07 08:21:50 [vdr] [14102] burn: MENU_M2V=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0/menu-background.m2v
May 07 08:21:50 [vdr] [14102] burn: MENU_MPEG=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0/menu-bg-0.mpg
May 07 08:21:50 [vdr] [14102] burn: MENU_SOUNDTRACK=/etc/vdr/plugins/burn/menu-silence.mp2
May 07 08:21:50 [vdr] [14102] burn: MENU_XML=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0/menu-0.xml
May 07 08:21:50 [vdr] [14094] burn: process render (pid = 14102) exited gracefully (exit code 0)
May 07 08:21:50 [vdr] [14094] burn: starting sh -c 'vdrburn-dvd.sh demux' (pid = 14109)
May 07 08:21:50 [vdr] [14109] burn: CONFIG_PATH=/etc/vdr/plugins/burn
May 07 08:21:50 [vdr] [14109] burn: IGNORE_TRACKS=
May 07 08:21:50 [vdr] [14109] burn: MPEG_DATA_PATH=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0
May 07 08:21:50 [vdr] [14109] burn: MPEG_TMP_PATH=/video/vdr-burn.Shaun_Of_The_Dead.zY1yze/VDRSYNC.0
May 07 08:21:50 [vdr] [14109] burn: RECORDING_PATH=/video/Bisha/%Shaun_Of_The_Dead/2013-04-28.01.54.5-0.rec
May 07 08:21:50 [vdr] [14109] burn: TTXT_OPTS=
May 07 08:21:50 [vdr] [14109] burn: USED_TRACKS=0xa6,0x80
May 07 08:21:50 [vdr] [14094] burn: starting sh -c 'vdrburn-dvd.sh author' (pid = 14110)
May 07 08:21:50 [vdr] [14110] burn: DVDAUTHOR_PATH=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/DVDAUTHOR
May 07 08:21:50 [vdr] [14110] burn: DVDAUTHOR_XML=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/dvd.xml
May 07 08:21:50 [vdr] [14110] burn: DVD_DEVICE=/dev/dvdrw
May 07 08:21:50 [vdr] [14110] burn: ISO_FILE=/Shaun Of The Dead.iso
May 07 08:21:50 [vdr] [14110] burn: VIDEO_FORMAT=PAL
May 07 08:21:58 [vdr] [14063] EnigmaNG effects thread ended (pid=13134, tid=14063)
May 07 08:22:03 [vdr] [14160] EnigmaNG effects thread started (pid=13134, tid=14160, prio=high)
May 07 08:22:56 [vdr] [14094] burn: px found type: Mpg Video
May 07 08:22:56 [vdr] [14094] burn: px found id: 0x00a6/0xe0, vdrsync.mpv
May 07 08:22:56 [vdr] [14094] burn: px found type: Mpg Audio
May 07 08:22:56 [vdr] [14094] burn: px found id: 0x0080/0xc0, vdrsync.mpa
May 07 08:23:01 [vdr] [14094] burn: process demux (pid = 14109) exited gracefully (exit code 0)
May 07 08:23:01 [vdr] [14094] burn: process "demux" exited
May 07 08:23:01 [vdr] [14094] burn: starting sh -c 'vdrburn-dvd.sh mplex' (pid = 14214)
May 07 08:23:01 [vdr] [14214] burn: AUDIO_FILES=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0/vdrsync.mpa
May 07 08:23:01 [vdr] [14214] burn: MOVIE_FILE=/video/vdr-burn.Shaun_Of_The_Dead.zY1yze/VDRSYNC.0/movie.mpg
May 07 08:23:01 [vdr] [14214] burn: MPEG_DATA_PATH=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0
May 07 08:23:01 [vdr] [14214] burn: MPEG_TMP_PATH=/video/vdr-burn.Shaun_Of_The_Dead.zY1yze/VDRSYNC.0
May 07 08:23:01 [vdr] [14214] burn: VIDEO_FILE=/video/vdr-burn.Shaun_Of_The_Dead.DLLw2r/VDRSYNC.0/vdrsync.mpv
May 07 08:23:58 [sshd] SSH: Server;LType: Throughput;Remote: 192.168.229.16-50053;IN: 3568;OUT: 1756;Duration: 1075.8;tPut_in: 3.3;tPut_out: 1.6
May 07 08:23:58 [sshd] pam_unix(sshd:session): session closed for user root
May 07 08:24:07 [vdr] [14160] EnigmaNG effects thread ended (pid=13134, tid=14160)
May 07 08:24:07 [vdr] [14284] EnigmaNG effects thread started (pid=13134, tid=14284, prio=high)
May 07 08:24:13 [vdr] [14284] EnigmaNG effects thread ended (pid=13134, tid=14284)
May 07 08:24:18 [vdr] [14094] burn: process mplex (pid = 14214) exited gracefully (exit code 1)
May 07 08:24:18 [vdr] [14094] burn: process "mplex" exited
May 07 08:24:18 [vdr] [14094] ERROR[burn]: process author (pid = 14110) crashed (signal 15)
May 07 08:24:18 [vdr] [14094] burn: subprocess watcher thread ended (pid=13134, tid=14094)
May 07 08:24:18 [vdr] [13173] burn: manager picked up finished job, removing it
May 07 08:24:18 [vdr] [13134] ERROR: Ein Auftrag ist fehlgeschlagen!
May 07 08:24:18 [vdr] [14293] EnigmaNG effects thread started (pid=13134, tid=14293, prio=high)


Kann mir einer von denen die Burn 0.2.2 erfolgreich am laufen haben einen Tip geben?

Viele Grüße
Kickaha
Email Poster
Top
franky
Geschrieben am: Dienstag, 07.Mai 2013, 09:39 Uhr
Quote Post


Prinz
****

Gruppe: Supporter
Beiträge: 1569
Mitgliedsnummer.: 1547
Mitglied seit: 2006-11-19



Hallo Kickaha,

da ist ein nicht existierendes iso-Verzeichnis als Default definiert.
Daher ist dann auch die Erstellung eines ISO-Files nicht möglich.

Die Verzeichnisse, die burn verwenden soll, kann man als Parameter in der /etc/vdr.d/plugins/burn mitgeben.
Hier ein Auszug aus der Plugin-Doku mit den Startparametern:
CODE
-t DIR,   --tempdir=DIR   use DIR for temporary files
                          MUST be on UNIX filesystem
                           (default: /tmp)
-d DIR,   --datadir=DIR   use DIR for temporary datafiles
                           (default: /var/spool/video)
-D DEV    --dvd=DEV       use DEV as DVD Writer
                           (default: /dev/dvdrw)
-i DIR    --iso=DIR       use DIR to store ISO images
                           (default: /pub/export)

Wenn Du also in der /etc/vdr.d/plugins/burn den folgende Parameter mitgibst
CODE
PLUGIN_PARAMETERS="-i /mnt/data/film"

werden ISOs, wie bisher bei Gen2VDR üblich, in /mnt/data/film erzeugt.

Du kannst hier natürlich jedes beliebige Verzeichnis definieren.
Aber es muss halt existieren.
Da das Default-Verzeichnis /pub/export bei Gen2VDR eben standardmäßig nicht existiert, ist es mit den Default Einstellungen auch nicht Möglich eine iso zu erzeugen.
Anstatt deiner Anpassung im Makefile für das tempdir, hättest Du auch den Paramerter -t verwenden können.

Gruß
Klaus
Email Poster
Top
Kickaha
Geschrieben am: Dienstag, 07.Mai 2013, 10:00 Uhr
Quote Post


Professional
****

Gruppe: Professionals
Beiträge: 350
Mitgliedsnummer.: 2030
Mitglied seit: 2007-05-25



Hallo franky,

das /pub/export Verzeichniss hatte ich vorher einfach mal angelegt. Das Problem ist aber, daß mir in den Burn Einstellungen als Ziel "Nur Abbild erstellen" gar nicht angeboten wird. Die Einstellung wird immer übersprungen.
Email Poster
Top
Kickaha
Geschrieben am: Dienstag, 07.Mai 2013, 10:04 Uhr
Quote Post


Professional
****

Gruppe: Professionals
Beiträge: 350
Mitgliedsnummer.: 2030
Mitglied seit: 2007-05-25



Ich korrigiere mich. Mit den ISO Parameter in /etc/vdr.d/plugins/burn funktioniert schonmal die Zielauswahl.
Email Poster
Top
Kickaha
Geschrieben am: Dienstag, 07.Mai 2013, 10:16 Uhr
Quote Post


Professional
****

Gruppe: Professionals
Beiträge: 350
Mitgliedsnummer.: 2030
Mitglied seit: 2007-05-25



Läuft aber trotzdem nicht durch.
CODE
May 07 11:07:41 [vdr] [9706] burn: process mplex (pid = 11473) exited gracefully (exit code 1)
May 07 11:07:41 [vdr] [9706] burn: process "mplex" exited
May 07 11:07:41 [vdr] [9706] ERROR[burn]: process author (pid = 9708) crashed (signal 15)
May 07 11:07:41 [vdr] [9706] burn: subprocess watcher thread ended (pid=2616, tid=9706)
May 07 11:07:42 [vdr] [2654] burn: manager picked up finished job, removing it
Email Poster
Top
franky
Geschrieben am: Dienstag, 07.Mai 2013, 13:03 Uhr
Quote Post


Prinz
****

Gruppe: Supporter
Beiträge: 1569
Mitgliedsnummer.: 1547
Mitglied seit: 2006-11-19



QUOTE (Kickaha @ Dienstag, 07.Mai 2013, 11:16 Uhr)
Läuft aber trotzdem nicht durch.
CODE
May 07 11:07:41 [vdr] [9706] burn: process mplex (pid = 11473) exited gracefully (exit code 1)
May 07 11:07:41 [vdr] [9706] burn: process "mplex" exited
May 07 11:07:41 [vdr] [9706] ERROR[burn]: process author (pid = 9708) crashed (signal 15)
May 07 11:07:41 [vdr] [9706] burn: subprocess watcher thread ended (pid=2616, tid=9706)
May 07 11:07:42 [vdr] [2654] burn: manager picked up finished job, removing it

Hi,

da hat mplex ein Problem mit der Aufnahme, die verarbeitet werden soll.

Dieses Problem ist schon seit burn-0.2.0-beta5 bekannt und wurde auch schon im vdr-portal diskutiert.
Es sind anscheinend auch nicht alle Aufnahmen betroffen und es muss daher nicht jedes Mal auftreten.
Mir ist es auch bei einigen Aufnahmen passiert, dass burn wegen mplex abgebrochen hat.

Zu dem mplex-Problem gibt es in dem VDR-Portal VDR-Portal Thema zu burn-0.2.0-beta5 für mplex, als Teil der mjpegtools, einen Patch.

Der hat für meine kritischen Aufnahmen auch bei burn-0.2.2 geholfen.
Ich hab dazu das ebuild für mjpegtools-2.0.0 sowie den patch an diese aktuelle Version der mjpegtools angepasst.

Dieses geänderte ebuild mit dem patch habe ich mal als Archiv angehängt.
Herunterladen, nach /tmp kopieren und wie folgt entpacken und mjpegtools emergen:
CODE
tar -C / -xf /tmp/mjpegtools.tgz
eix-sync
emerge -av =media-video/mjpegtools-2.0.0-r3

Es wird dabei nicht das ebuild im Master Portage überschrieben, sondern das geänderte ebuild und der patch werden in das local Portage entpackt.

Gruß
Klaus

angehängte Datei ( Anzahl der Downloads: 136 )
angehängte Datei  mjpegtools.tgz
Email Poster
Top
R2D2
Geschrieben am: Dienstag, 07.Mai 2013, 13:22 Uhr
Quote Post


Prinz
****

Gruppe: Moderators
Beiträge: 6016
Mitgliedsnummer.: 1131
Mitglied seit: 2005-10-30



Ich verwende burn eigentlich nicht, aber ich habe aber mal spaßeshalber die aktuelle Version (0.2.2) installiert und die Änderungen von NetWraith einfach "blind" übernommen.

Damit funktioniert es bei mir mir vdr-2.0.1 ohne Probleme. ;)

Das Brennen selber habe ich nicht getestet, ich habe mir nur ein paar ISOs erzeugen lassen.
Email PosterUsers WebsiteICQ
Top
kaminkehrer
Geschrieben am: Dienstag, 07.Mai 2013, 16:50 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 1068
Mitgliedsnummer.: 300
Mitglied seit: 2004-02-08



Hallo,

ich habe das TMPDIR einfach in der "vdrburn-dvd.conf" definiert.



CODE
# settings for vdrburn-dvd.sh
TMPDIR="/mnt/data/tmpburn"


Natürlich habe ich das Verzeichnis vorher angelegt
CODE
mkdir /mnt/data/tmpburn


Viele Grüße
kaminkehrer
Email Poster
Top
Thema wird von 0 Benutzer(n) gelesen (0 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic OptionsSeiten: (2) [1] 2  Reply to this topicStart new topicStart Poll