Powered by Invision Power Board


  
 
Reply to this topicStart new topicStart Poll

> [gelöst] Kodi speichert Skineinstellungen nicht
2skunky
Geschrieben am: Samstag, 22.April 2017, 20:37 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 58
Mitgliedsnummer.: 16367
Mitglied seit: 2011-12-18



Hallo Zusammen,

nach langer Zeit habe ich heute auf V6.5 geupdated.
Erstmal einen herzlichen Dank für für die super Arbeit Helmut!
Ein kleines Problem habe ich allerding im Moment.
Wenn ich im Kodi Einstellungen am Skin vornehme, in diesem Falle Einträge aus dem Hauptmenü ausblende, werden diese Settings nicht gespeichert. Ich wechsel von Kodi auf den VDR und zurück da sind dann alle ausgeblendeten Menüpunkte wieder da. :(
Hat dieses Verhalten noch irgendwer beobachtet oder bin ich der einzige der das Hauptmenü anpasst?
Alle anderen Einstellungen wurden scheinbar gespeichert, zumindest Accounts (Youtube), neue Quellen und Bibliotheken.
Wäre aber sehr schon wenn auch der Skin "wechselfest" wird.
Logfiles sind angehangen.

Grüße

2skunky

angehängte Datei ( Anzahl der Downloads: 7 )
angehängte Datei  g2v_log_04222125.tar.xz
Email Poster
Top
SVeith
Geschrieben am: Sonntag, 23.April 2017, 10:16 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 503
Mitgliedsnummer.: 1160
Mitglied seit: 2005-11-10



QUOTE (2skunky @ Samstag, 22.April 2017, 20:37 Uhr)
...
Hat dieses Verhalten noch irgendwer beobachtet oder bin ich der einzige der das Hauptmenü anpasst?
...

Habe das Verhalten ebenfalls, aber noch nicht nach einer Lösung gesucht.
Email Poster
Top
HelAu
Geschrieben am: Sonntag, 23.April 2017, 11:37 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 10960
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



Passiert dies auch wenn Ihr Kodi mittels Tastatur über "Verlassen" beendet ?
Email PosterUsers WebsiteICQAOLYahoo
Top
2skunky
Geschrieben am: Sonntag, 23.April 2017, 16:39 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 58
Mitgliedsnummer.: 16367
Mitglied seit: 2011-12-18



Hi,

also ich habe das gerade mal getestet, dabei hab ich ein sehr seltsames Verhalten festgestellt.
Wenn ich Kodi über den Menüpunkt "Verlassen" beende, kann ich erst beim zweiten Versuch wieder starten. Beim ersten Versuch wird scheinbar versucht Kodi zu starten, aber es wird direkt wieder beendet und die Box steht wieder im Launcher.
Ich hab mir mal das Messages und das Kodi Log angeschaut und ein Diff über einen Successfull Start und einen Fail laufen lassen, dabei scheint es eben so zu sein das Kodi direkt wieder beendet wird.

Die beiden Logauszüge sind bis Zeile 100 nahezu identisch.
Nach weiteren 11 Zeilen ist das Succesfull zu Ende, beim Fail sind aber noch weitere 78 Zeilen.

Dies scheint mir die entscheidende Zeile im kodi_fail.log:
CODE

17:25:42.819 T:139661801326592   ERROR: CSettings: error loading settings definition from special://xbmc/system/settings/settings.xml, Line 0
                                           Failed to open file
17:25:42.819 T:139661801326592   FATAL: Unable to load settings definitions

Leider weiß ich nicht genau wie es dazu kommt.


Gruß
Justus

P.S. schlate ich übers Skript hin und her klappt alles nach wie vor, außer den Menüeinträgen natürlich ;)

angehängte Datei ( Anzahl der Downloads: 7 )
angehängte Datei  logpack_kodi_messages.zip
Email Poster
Top
2skunky
Geschrieben am: Sonntag, 23.April 2017, 16:47 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 58
Mitgliedsnummer.: 16367
Mitglied seit: 2011-12-18



Achso ich hab auch nochmal geschaut ob das File:
CODE

/usr/share/kodi/system/settings/settings.xml

auch nach dem "Verlassen" existiert.
Dem ist so und der Inhalt ist auch identisch, von daher liegt es nicht an der Datei selber.
Email Poster
Top
HelAu
Geschrieben am: Mittwoch, 26.April 2017, 09:16 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 10960
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



Das ist ein Bug in Kodi. Wenn Du nach dem Ändern der Hauptmenueinträge einmal den Skin wechselst und dann wieder zurück dann merkt sichs Kodi ...
Email PosterUsers WebsiteICQAOLYahoo
Top
2skunky
  Geschrieben am: Mittwoch, 26.April 2017, 21:18 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 58
Mitgliedsnummer.: 16367
Mitglied seit: 2011-12-18



Besten dank Helmut.
Das hat geklappt.
Vielen vielen dank für den wie immer spitzenmäßigen Support!!!
Email Poster
Top
Thema wird von 1 Benutzer(n) gelesen (1 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic Options Reply to this topicStart new topicStart Poll