Druckbare Version des Themas
Hier klicken um das Thema im Original Format zu betrachten.
HTPC Forum > Installation/Konfiguration > [gelöst] V6 DVD automoumt


Geschrieben von: eule am Sonntag, 20.August 2017, 15:00 Uhr
Hallo zusammen,

habe den neuen V6 auf alter Hardware installiert. Läuft soweit
alles OTP. Selbst meine alte B2B Flex wurde ohne Handarbeit
erkannt. Danke erstmal an alle für die Arbeit.

Leider habe ich noch ein Problem. Hatte ich schon beim 5.3.
DVDs werden nicht automatisch gemountet. Da hilft nur ein

CODE

mount /dev/sr0


Der Bugfix mit der g2v_automount.sh vom 5.3 hat nicht
geholfen. Hat jemand eine Lösung ?

VG
Jörg

Geschrieben von: HelAu am Sonntag, 20.August 2017, 21:27 Uhr
Hi,

Mach mal:

CODE
ln -sf blkid /sbin/blk_id


Und ein Ticket im Bugtracker auf smile.gif

Geschrieben von: eule am Montag, 21.August 2017, 19:25 Uhr
Ticket habe ich aufgemacht.

Zum testen komme ich erst am WE. Bin zur Zeit
400 km von der Kiste entfernt.

Danke für die schnelle Antwort.

VG
Jörg

Geschrieben von: eule am Sonntag, 27.August 2017, 16:30 Uhr
Hat leider nicht geholfen.

VG
Jörg

Geschrieben von: R2D2 am Sonntag, 27.August 2017, 17:17 Uhr
QUOTE
CODE
...
[So Aug 27 16:58:12 2017] sr 4:0:0:0: [sr0] tag#24 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[So Aug 27 16:58:12 2017] sr 4:0:0:0: [sr0] tag#24 Sense Key : 0x5 [current]
[So Aug 27 16:58:12 2017] sr 4:0:0:0: [sr0] tag#24 ASC=0x6f ASCQ=0x3
[So Aug 27 16:58:12 2017] sr 4:0:0:0: [sr0] tag#24 CDB: opcode=0x28 28 00 00 39 c5 c0 00 00 40 00
[So Aug 27 16:58:12 2017] blk_update_request: I/O error, dev sr0, sector 15144704
...


- Ist das eine selbst gebrannte DVD?
- Funktionieren denn gekaufte DVDs?

Geschrieben von: HelAu am Sonntag, 27.August 2017, 17:49 Uhr
Was gibt denn:
CODE
udevadm info --query=all --name=/dev/sr0 2>/dev/null | grep " ID_TYPE=cd"

aus und bei eingelegter DVD:
CODE
blkid /dev/sr0

Geschrieben von: eule am Sonntag, 27.August 2017, 17:50 Uhr
@R2D2

Das war eine gekaufte DVD. Selbst gebrannte funktionieren auch nicht.
Nur über die Konsole mit mount.

Geschrieben von: eule am Sonntag, 27.August 2017, 18:07 Uhr
@HelAu



CODE

vdr01 ~ # udevadm info --query=all --name=/dev/sr0 2>/dev/null | grep " ID_TYPE=cd"
E: ID_TYPE=cd


CODE

vdr01 ~ # blkid /dev/sr0
/dev/sr0: UUID="2004-10-12-13-51-42-00" LABEL="I_ROBOT_SPECIAL_EDITION_DISC_1" TYPE="udf"

Geschrieben von: HelAu am Sonntag, 27.August 2017, 18:16 Uhr
Ändere mal in der /_config/bin/g2v_automount.sh
Zeile 105-107 von:
CODE
              if [ $CDSTAT -ge 4 ]; then
                 execCmd "pmount /dev/$i"
              fi

in
CODE
#               if [ $CDSTAT -ge 4 ]; then
                 execCmd "pmount /dev/$i"
#               fi

Geschrieben von: eule am Sonntag, 27.August 2017, 19:22 Uhr
Danke.

Jetzt funktionierts.

VG
Jörg

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)