Powered by Invision Power Board


  
 
Reply to this topicStart new topicStart Poll

> Wie tägliches Hochfahren deaktivieren?
pacman
Geschrieben am: Samstag, 01.April 2017, 19:49 Uhr
Quote Post


Advanced Member
***

Gruppe: Active Members
Beiträge: 11
Mitgliedsnummer.: 16884
Mitglied seit: 2017-03-25



Hallo,

mein Rechner mit gen2vdr (5.0, erst kürzlich installiert) fährt sich täglich hoch, obwohl kein timer o.Ä. gesetzt ist. Vermutlich lässt sich das durch eine Einstellung abstellen, sodass sich der Rechner nur noch für den nächsten gesetzten timer hochfährt. Als Wakeup Methode habe ich ACPI eingestellt und würde das auch gern weiter verwenden.

Kann mir jemand einen Tip geben, wo & wie ich das so konfigurieren kann? Oder geht das evtl. gar nicht auf einfache Art und Weise?

Danke!
pacman

Email Poster
Top
R2D2
Geschrieben am: Samstag, 01.April 2017, 20:49 Uhr
Quote Post


Prinz
****

Gruppe: Moderators
Beiträge: 5979
Mitgliedsnummer.: 1131
Mitglied seit: 2005-10-30



Vermutlich ist "Taegliches Aufwachen fuer Wartung (EPG-Scan...)" aktiviert.
Email PosterUsers WebsiteICQ
Top
pacman
Geschrieben am: Sonntag, 02.April 2017, 11:17 Uhr
Quote Post


Advanced Member
***

Gruppe: Active Members
Beiträge: 11
Mitgliedsnummer.: 16884
Mitglied seit: 2017-03-25



Unter dem Punkt ist aktuell eingestellt:
Tgl Wakeup-Zeit: 5
Tgl Dauer: 0 <--- damit sollte das tägl. Wakeup deaktiv sein, oder?
EPG-Daten bei Wakeup: Aus

Bei Suspend to Ram Besonderheiten
DailyWakeup Limit (Stunden): 5
ManualWakeup Limit(Tage): 1

Ist an der config noch etwas falsch, das den tägl. wakeup verursachen könnte?

pacman
Email Poster
Top
pacman
Geschrieben am: Sonntag, 02.April 2017, 12:08 Uhr
Quote Post


Advanced Member
***

Gruppe: Active Members
Beiträge: 11
Mitgliedsnummer.: 16884
Mitglied seit: 2017-03-25



Ich habe mir mal das script /_config/bin/vdrshutdown.sh angesehen. Kann es sein, dass per ACPI-Wakeup gar kein timer in später als 24h möglich ist?

Bei set_acpi_timer() steht:
# check if NEXT_TIMER is within next 24 hours

Falls das zutrifft (und ich das script richtig lese) wird die Zeit des timers gesetzt, andernfalls in genau 24h relativ zur aktuellen Zeit ein wakeup gesetzt. Oder hab ich da was übersehen? Würde dann genau das beobachtete Verhalten erklären. Sollte ein ACPI wakeup > 24h nicht möglich sein?

Grüße
pacman
Email Poster
Top
MegaV0lt
Geschrieben am: Sonntag, 02.April 2017, 15:04 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 760
Mitgliedsnummer.: 544
Mitglied seit: 2005-06-01



Ist vielleicht im BIOS ein täglicher Wakeup eingestellt?
Ansonsten wäre ein Log hilfreich
Email PosterUsers WebsiteICQ
Top
HelAu
Geschrieben am: Sonntag, 02.April 2017, 16:35 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 11014
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



So ein Logpaket wäre ganz generell hilfreich :)
Email PosterUsers WebsiteICQAOLYahoo
Top
pacman
Geschrieben am: Sonntag, 02.April 2017, 17:14 Uhr
Quote Post


Advanced Member
***

Gruppe: Active Members
Beiträge: 11
Mitgliedsnummer.: 16884
Mitglied seit: 2017-03-25



Im BIOS hab ich kein regelmäßiges Hochfahren aktiviert.

Logpaket mal anbei.

Grüße
pacman

angehängte Datei ( Anzahl der Downloads: 27 )
angehängte Datei  g2v_log_04021804.tar.xz
Email Poster
Top
HelAu
Geschrieben am: Sonntag, 02.April 2017, 18:10 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 11014
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



In dem Log sieht man jetzt nur Herunterfahren mit einem anstehenden Timer.
Wenn das mal wieder auftritt dann zieh am besten davon direkt ein Logfile
P.S. Ja Du hast Recht früher war ein Wakeup jenseits der 24H nicht möglich. Mag sein dass neuere "BIOSSE" das können, das müsste man mal antesten ....
Schreib doch mal ein Feature Request im Bugtracker dann mach ich das einstellbar
Email PosterUsers WebsiteICQAOLYahoo
Top
pacman
Geschrieben am: Sonntag, 02.April 2017, 21:26 Uhr
Quote Post


Advanced Member
***

Gruppe: Active Members
Beiträge: 11
Mitgliedsnummer.: 16884
Mitglied seit: 2017-03-25



Ich hab mal ein altes log (messages) gefunden, in dem man das Verhalten sieht - oder bräuchtest du noch andere files? Falls ja erzeug ich ein komplett-log ein ander mal...

Feature request ist eingetragen.

Ich kann gern anbieten das ACPI wakeup zu testen, wobei bei mir die ganzen letzten Jahre (vor Wechsel auf gen2vdr 5.0) m.W. immer per ACPI wakeup auf den nächsten timer gestartet wurde - ohne Zwischenstarts alle 24h. Aber da kann ich bei Gelegenheit zur Sicherheit nochmal in die config schauen...

Danke & Grüße
pacman

angehängte Datei ( Anzahl der Downloads: 27 )
angehängte Datei  messages.tar.gz
Email Poster
Top
HelAu
Geschrieben am: Sonntag, 02.April 2017, 21:28 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 11014
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



Bist Du da ganz sicher dass dies bei älteren Gen2VDR Versionen nicht so war ? An der Stelle hab ich schon ewig nichts mehr geändert ...
Email PosterUsers WebsiteICQAOLYahoo
Top
MegaV0lt
Geschrieben am: Montag, 03.April 2017, 08:09 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 760
Mitgliedsnummer.: 544
Mitglied seit: 2005-06-01



In Deinem Log steht aber ein Timer an und wird auch gesetzt:
CODE
Mar 29 20:10:01 [G2V vdrshutdown.sh] /_config/bin/vdrshutdown.sh -1490983500-172499-22-Hubert und Staller (55)-0-
...
Mar 29 20:10:02 [vdr] [3868] SVDRP message: 'System wird heruntergefahren'
...
Mar 29 20:10:05 [G2V vdrshutdown.sh] Next acpi alarm at: 1490897404
Mar 29 20:10:05 [logger] rtc_time_: 18:10:05
Mar 29 20:10:05 [logger] rtc_date_: 2017-03-29
Mar 29 20:10:05 [logger] alrm_time_: 18:10:04
Mar 29 20:10:05 [logger] alrm_date_: 2017-03-30
Mar 29 20:10:05 [logger] alarm_IRQ_: yes
Mar 29 20:10:05 [logger] alrm_pending_: no
Mar 29 20:10:05 [logger] update IRQ enabled_: no
Mar 29 20:10:05 [logger] periodic IRQ enabled_: no
Mar 29 20:10:05 [logger] periodic IRQ frequency_: 1024
Mar 29 20:10:05 [logger] max user IRQ frequency_: 64
Mar 29 20:10:05 [logger] 24hr__: yes
Mar 29 20:10:05 [logger] periodic_IRQ_: no
Mar 29 20:10:05 [logger] update_IRQ_: no
Mar 29 20:10:05 [logger] HPET_emulated_: no
Mar 29 20:10:05 [logger] BCD__: yes
Mar 29 20:10:05 [logger] DST_enable_: no
Mar 29 20:10:05 [logger] periodic_freq_: 1024
Mar 29 20:10:05 [logger] batt_status_: okay
Email PosterUsers WebsiteICQ
Top
MegaV0lt
Geschrieben am: Montag, 03.April 2017, 08:15 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 760
Mitgliedsnummer.: 544
Mitglied seit: 2005-06-01



Ich habe mal die Sekunden umgerechnet:
CODE
Mar 29 20:10:01 [G2V vdrshutdown.sh] /_config/bin/vdrshutdown.sh -1490983500-172499-22-Hubert und Staller (55)-0-

date -d @1490983500
=> Fr 31. Mär 20:05:00 CEST 2017

CODE
Mar 29 20:10:05 [G2V vdrshutdown.sh] Next acpi alarm at: 1490897404

date -d @1490897404
=> Do 30. Mär 20:10:04 CEST 2017

Da wird tatsächlich ein Tag abgezogen...

Im Skript passiert die Begrenzung auf einen Tag wohl ab Zeile 73:
CODE
     # check if NEXT_TIMER is within next 24 hours
     WAKEUP="$(date -d "1 day" +%s)"
     if [[ $1 -lt $WAKEUP ]]; then
        WAKEUP="$1"
     else
        NEXT_TIMER="$WAKEUP"
     fi

Ich vermute mal einen Grund im BIOS. Wahrscheinlich können das nicht viele...
Zum testen könnte man das konfigurierbar machen...

@pacman
Kommentiere testweise einfach mal wie folgt aus:
CODE
     # check if NEXT_TIMER is within next 24 hours
     # WAKEUP="$(date -d "1 day" +%s)"
     # if [[ $1 -lt $WAKEUP ]]; then
        WAKEUP="$1"
     # else
     #    NEXT_TIMER="$WAKEUP"
     # fi

So dass nur noch das WAKEUP="$1" übrig bleibt. Kann aber sein, dass dann kein Timer mehr geht, der mehr als 24 Stunden weg ist
Email PosterUsers WebsiteICQ
Top
pacman
Geschrieben am: Mittwoch, 05.April 2017, 18:47 Uhr
Quote Post


Advanced Member
***

Gruppe: Active Members
Beiträge: 11
Mitgliedsnummer.: 16884
Mitglied seit: 2017-03-25



@MegaV0lt

Ja, die code-Anpassung hab ich gemacht und der Rechner ist (wie erhofft/erwartet) in >24h aufgewacht. Konkret: Shutdown am Montag um ca. 4h, Wakeup am Mittwoch ca. 18h.

@HelAu

Ich werde demnächst nochmal genau kontrollieren, welche Version ich vorher hatte (soweit ich das irgendwie herausbekommen kann). Da muss ich aber die alte Platte wieder dranhängen, daher wird's wohl eher Wochenende, bis ich dazu komme. Ich melde mich dazu nochmal.

Danke für die Unterstützung!

Grüße
pacman

Email Poster
Top
HelAu
Geschrieben am: Mittwoch, 05.April 2017, 19:52 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 11014
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



@Pacman
Ist nicht nötig nachzuschauen, ich werd das so dann einbauen
Email PosterUsers WebsiteICQAOLYahoo
Top
MegaV0lt
Geschrieben am: Freitag, 07.April 2017, 14:37 Uhr
Quote Post


Professional
****

Gruppe: G2V3+User
Beiträge: 760
Mitgliedsnummer.: 544
Mitglied seit: 2005-06-01



Aber es stellt sich doch die Frage, warum das mal so eingebaut wurde.

Kann es sein, dass bei einigen Boards das BIOS das gar nicht kann und diese dann gar nicht aufwachen?

Irgendwo hab ich gelesen, dass wenn da **** drin sind, das BIOS das nicht kann:
CODE
Mar 29 20:10:05 [logger] alrm_date_: 2017-03-30
Mar 29 20:10:05 [logger] alrm_date_: ****-03-30 <- Beispiel

Kann man das nicht irgendwo auslesen? Und wenn ja, dann am besten automatisch konfigurieren oder zur Not über das admin-Plugin...
Email PosterUsers WebsiteICQ
Top
Thema wird von 1 Benutzer(n) gelesen (1 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic Options Reply to this topicStart new topicStart Poll