Druckbare Version des Themas
Hier klicken um das Thema im Original Format zu betrachten.
HTPC Forum > XBMC > [gelöst] Kodi speichert Skineinstellungen nicht


Geschrieben von: 2skunky am Samstag, 22.April 2017, 20:37 Uhr
Hallo Zusammen,

nach langer Zeit habe ich heute auf V6.5 geupdated.
Erstmal einen herzlichen Dank für für die super Arbeit Helmut!
Ein kleines Problem habe ich allerding im Moment.
Wenn ich im Kodi Einstellungen am Skin vornehme, in diesem Falle Einträge aus dem Hauptmenü ausblende, werden diese Settings nicht gespeichert. Ich wechsel von Kodi auf den VDR und zurück da sind dann alle ausgeblendeten Menüpunkte wieder da. sad.gif
Hat dieses Verhalten noch irgendwer beobachtet oder bin ich der einzige der das Hauptmenü anpasst?
Alle anderen Einstellungen wurden scheinbar gespeichert, zumindest Accounts (Youtube), neue Quellen und Bibliotheken.
Wäre aber sehr schon wenn auch der Skin "wechselfest" wird.
Logfiles sind angehangen.

Grüße

2skunky

Geschrieben von: SVeith am Sonntag, 23.April 2017, 10:16 Uhr
QUOTE (2skunky @ Samstag, 22.April 2017, 20:37 Uhr)
...
Hat dieses Verhalten noch irgendwer beobachtet oder bin ich der einzige der das Hauptmenü anpasst?
...

Habe das Verhalten ebenfalls, aber noch nicht nach einer Lösung gesucht.

Geschrieben von: HelAu am Sonntag, 23.April 2017, 11:37 Uhr
Passiert dies auch wenn Ihr Kodi mittels Tastatur über "Verlassen" beendet ?

Geschrieben von: 2skunky am Sonntag, 23.April 2017, 16:39 Uhr
Hi,

also ich habe das gerade mal getestet, dabei hab ich ein sehr seltsames Verhalten festgestellt.
Wenn ich Kodi über den Menüpunkt "Verlassen" beende, kann ich erst beim zweiten Versuch wieder starten. Beim ersten Versuch wird scheinbar versucht Kodi zu starten, aber es wird direkt wieder beendet und die Box steht wieder im Launcher.
Ich hab mir mal das Messages und das Kodi Log angeschaut und ein Diff über einen Successfull Start und einen Fail laufen lassen, dabei scheint es eben so zu sein das Kodi direkt wieder beendet wird.

Die beiden Logauszüge sind bis Zeile 100 nahezu identisch.
Nach weiteren 11 Zeilen ist das Succesfull zu Ende, beim Fail sind aber noch weitere 78 Zeilen.

Dies scheint mir die entscheidende Zeile im kodi_fail.log:
CODE

17:25:42.819 T:139661801326592   ERROR: CSettings: error loading settings definition from special://xbmc/system/settings/settings.xml, Line 0
                                           Failed to open file
17:25:42.819 T:139661801326592   FATAL: Unable to load settings definitions

Leider weiß ich nicht genau wie es dazu kommt.


Gruß
Justus

P.S. schlate ich übers Skript hin und her klappt alles nach wie vor, außer den Menüeinträgen natürlich wink.gif

Geschrieben von: 2skunky am Sonntag, 23.April 2017, 16:47 Uhr
Achso ich hab auch nochmal geschaut ob das File:
CODE

/usr/share/kodi/system/settings/settings.xml

auch nach dem "Verlassen" existiert.
Dem ist so und der Inhalt ist auch identisch, von daher liegt es nicht an der Datei selber.

Geschrieben von: HelAu am Mittwoch, 26.April 2017, 09:16 Uhr
Das ist ein Bug in Kodi. Wenn Du nach dem Ändern der Hauptmenueinträge einmal den Skin wechselst und dann wieder zurück dann merkt sichs Kodi ...

Geschrieben von: 2skunky am Mittwoch, 26.April 2017, 21:18 Uhr
Besten dank Helmut.
Das hat geklappt.
Vielen vielen dank für den wie immer spitzenmäßigen Support!!!

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)