Powered by Invision Power Board Schnäppchenticker


  
 
Reply to this topicStart new topicStart Poll

> [Gelöst] Versionskonflikt nach Treiberupdate, API MISMATCH ... bei Nvidia 290.20
NetWraith
  Geschrieben am: Montag, 20.Februar 2012, 12:49 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 452
Mitgliedsnummer.: 12782
Mitglied seit: 2010-03-20



Hallo,

bei meinem gestrigen WOrld-Update, habe ich auch meine Graphiktreiber von NVidia auf Version 290.20 geuppt.

Nach einem Neustart des Systems blieb der Bildschirm mit Xineliboutput nur hell.
Streaming via xineliboutput geht, sowie der Launcher, XBMC und die andern Apps (wie FireFox).

Wenn ich dmesg eingebe, bekomme ich unteranderem folgenden Output:
CODE
NVRM: API mismatch: the client has the version 270.18, but
NVRM: this kernel module has the version 295.20.  Please
NVRM: make sure that this kernel module and all NVIDIA driver


Auszug aus /log/everything/current (hell blinkender Schirm):
CODE
Feb 20 12:31:34 [logger] /_config/bin/vdr-xine.sh - starte <vdr-sxfe --fullscreen --config=/root/.xine/config_xineliboutput --video=vdpau --audio=alsa --reconnect --aspect=16:9 xvdr://127.0.0.1>
Feb 20 12:31:34 [logger] /_config/bin/gg_switchhook.sh -switch ActWin <(1078, 1918) 1(Connecting to VDR ...)>
Feb 20 12:31:34 [kernel] NVRM: API mismatch: the client has the version 270.18, but
Feb 20 12:31:34 [kernel] NVRM: this kernel module has the version 295.20.  Please
Feb 20 12:31:34 [kernel] NVRM: make sure that this kernel module and all NVIDIA driver
Feb 20 12:31:34 [kernel] NVRM: components have the same version.
Feb 20 12:31:35 [logger] Aspect ratio: 16:9
Feb 20 12:31:35 [logger] VDR Server: xvdr://127.0.0.1
Feb 20 12:31:35 [logger] Available video drivers: vdpau dxr3 aadxr3 xv raw opengl aa caca xshm xxmc none sdl vidix vidixfb fb xvmc
Feb 20 12:31:35 [logger] Available audio drivers: pulseaudio alsa oss jack none file
Feb 20 12:31:35 [logger] /_config/bin/gg_switchhook.sh -switch ActWin <(1078, 1918) 0(Gg_launcher)>
Feb 20 12:31:35 [logger] xine gui died (251)
Feb 20 12:31:36 [logger] Focus: (1078, 1918) 0(Gg_launcher) - 4138
Feb 20 12:31:36 [logger] Focus: 0
Feb 20 12:31:36 [logger] Focus: 1
Feb 20 12:31:36 [logger] /_config/bin/vdr-xine.sh - starte <vdr-sxfe --fullscreen --config=/root/.xine/config_xineliboutput --video=vdpau --audio=alsa --reconnect --aspect=16:9 xvdr://127.0.0.1>
Feb 20 12:31:36 [logger] /_config/bin/gg_switchhook.sh -switch ActWin <(1078, 1918) 1(Connecting to VDR ...)>
Feb 20 12:31:36 [kernel] NVRM: API mismatch: the client has the version 270.18, but
Feb 20 12:31:36 [kernel] NVRM: this kernel module has the version 295.20.  Please
Feb 20 12:31:36 [kernel] NVRM: make sure that this kernel module and all NVIDIA driver
Feb 20 12:31:36 [kernel] NVRM: components have the same version.
Feb 20 12:31:36 [logger] Aspect ratio: 16:9
Feb 20 12:31:36 [logger] VDR Server: xvdr://127.0.0.1
Feb 20 12:31:36 [logger] Available video drivers: vdpau dxr3 aadxr3 xv raw opengl aa caca xshm xxmc none sdl vidix vidixfb fb xvmc
Feb 20 12:31:36 [logger] Available audio drivers: pulseaudio alsa oss jack none file
Feb 20 12:31:36 [logger] xine gui died (251)
Feb 20 12:31:36 [logger] /_config/bin/gg_switchhook.sh -switch ActWin <(1078, 1918) 0(Gg_launcher)>
Feb 20 12:31:37 [logger] /_config/bin/vdr-xine.sh - starte <vdr-sxfe --fullscreen --config=/root/.xine/config_xineliboutput --video=vdpau --audio=alsa --reconnect --aspect=16:9 xvdr://127.0.0.1>
Feb 20 12:31:37 [logger] /_config/bin/gg_switchhook.sh -switch ActWin <(1078, 1918) 1(Connecting to VDR ...)>
Feb 20 12:31:37 [kernel] NVRM: API mismatch: the client has the version 270.18, but
Feb 20 12:31:37 [kernel] NVRM: this kernel module has the version 295.20.  Please
Feb 20 12:31:37 [kernel] NVRM: make sure that this kernel module and all NVIDIA driver
Feb 20 12:31:37 [kernel] NVRM: components have the same version.
Feb 20 12:31:38 [logger] Focus: (1078, 1918) 1(Connecting to VDR ...) - 4138
Feb 20 12:31:38 [logger] Focus: 0
Feb 20 12:31:38 [logger] Focus: 1
Feb 20 12:31:38 [logger] Aspect ratio: 16:9
Feb 20 12:31:38 [logger] VDR Server: xvdr://127.0.0.1
Feb 20 12:31:38 [logger] Available video drivers: vdpau dxr3 aadxr3 xv raw opengl aa caca xshm xxmc none sdl vidix vidixfb fb xvmc
Feb 20 12:31:38 [logger] Available audio drivers: pulseaudio alsa oss jack none file
Feb 20 12:31:38 [logger] xine gui died (251)


Wie es scheint, wurde das Kernelmodul hochgezogen, aber der restliche Treiber nicht.

Ich habe anschließend den NVidiatreiber und die Settings deemerged und nochmals neu installiert. -> gleiches Problem

Hat einer der Cracks nen Rat für mich ?

mni tnx e 73 de ...
NetWraith
Email Poster
Top
motorsense
Geschrieben am: Montag, 20.Februar 2012, 14:24 Uhr
Quote Post


Advanced Member
***

Gruppe: G2V3+User
Beiträge: 98
Mitgliedsnummer.: 3327
Mitglied seit: 2007-12-25



Hallo NetWraith,

anscheinend wurde der Nvidia Treiber 270.18 mal ohne emerge installiert. Hatte das Problem auch. Habe zuerst nvidia-drivers und nvidia-settings deinstalliert. Dann habe ich mir das Installpaket des Nvidia Treibers 270.18 von der Nvidia Seite geladen und mit dem Parameter --uninstall ausgeführt. Dann nvidia-drivers und settings neu emerged und alles war gut. Hoffe es hilft.

Gruß

Oli
Email Poster
Top
HelAu
Geschrieben am: Montag, 20.Februar 2012, 15:17 Uhr
Quote Post


Scheffe
****

Gruppe: Admin
Beiträge: 10181
Mitgliedsnummer.: 2
Mitglied seit: 2003-04-25



Email PosterUsers WebsiteICQAOLYahoo
Top
R2D2
Geschrieben am: Montag, 20.Februar 2012, 18:04 Uhr
Quote Post


Prinz
****

Gruppe: Moderators
Beiträge: 5359
Mitgliedsnummer.: 1131
Mitglied seit: 2005-10-30



QUOTE (NetWraith @ Montag, 20.Februar 2012, 12:49 Uhr)
[...] Wenn ich dmesg eingebe, bekomme ich unteranderem folgenden Output:
CODE
NVRM: API mismatch: the client has the version 270.18, but
NVRM: this kernel module has the version 295.20.  Please
NVRM: make sure that this kernel module and all NVIDIA driver



Jetzt bin bin ich aber beruhigt, denn ich dachte schon, ich wäre zu doof für ein world Update.
Ich hatte auch ganz genau das beschriebene Problem.
Nichts hat geholfen, weder ein downgrade des Treibers, noch ein Kernelupdate.
Auch der von HelAu gepostet Link hat bei mir nicht geholfen.

Ich wollte schon das Backup einspielen, dann habe ich aber folgendes gemacht:

CODE
sh /mnt/data/portage/distfiles/NVIDIA-Linux-x86-295.20.run
reboot
--> Evtl. gewünschte Treiberversion anpassen.

dann:

CODE
emerge -av nvidia-drivers


Dann war wieder alles in Butter. ;)
Email PosterUsers WebsiteICQ
Top
NetWraith
Geschrieben am: Montag, 20.Februar 2012, 18:21 Uhr
Quote Post


Professional
****

Gruppe: Supporter
Beiträge: 452
Mitgliedsnummer.: 12782
Mitglied seit: 2010-03-20



Vielen Dank für Eure Hilfe ... und daß ich nicht alleine bin ;) . Hier meine Lösung auf Basis von MotorSense:

CODE
emerge -aC nvidia-drivers nvidia-settings
cd /tmp
wget http://de.download.nvidia.com/XFree86/Linux-x86/270.18/NVIDIA-Linux-x86-270.18.run
chmod 755 NVIDIA-Linux-x86-270.18.run
./NVIDIA-Linux-x86-270.18.run --uninstall
reboot

eix-sync
emerge -av nvidia-drivers nvidia-settings


vy 55 ...
NetWraith
Email Poster
Top
Thema wird von 1 Benutzer(n) gelesen (1 Gäste und 0 Anonyme Benutzer)
0 Mitglieder:

Topic Options Reply to this topicStart new topicStart Poll