Druckbare Version des Themas
Hier klicken um das Thema im Original Format zu betrachten.
HTPC Forum > VDR > VDR 2.3.7 - Probleme mit Plugins


Geschrieben von: MegaV0lt am Dienstag, 13.Juni 2017, 14:32 Uhr
Ich wollte mal wieder testen, ob ich den VDR ab 2.3.x zum laufen bekomme.

Ich habe die Original Sourcen geladen udn meine benötigten Plugins aus dem Paket von hier (vdr-2.3.4) rein kopiert.

Einen Patch habe ich angewendet: Menuselection
Die Make.config und Make.plgcfg habe ich aus dem Paket (vdr-2.3.4) genommen.

Das Buildsktipt bringt mir am Ende zwei Plugins, die nicht gebaut werden konnten: OSDTeletext und SoftHHDevice.

Hier das ganze log: https://www.dropbox.com/s/e79b66til8et3fv/build-vdr2.log?dl=0

PS:: Das vdr-2.3.4 Paket hat auch nicht gebaut, weshalb ich gleich mit 2.3.7 weiter gemacht habe

PPS: Hier die Auszüge der Plugins:
- https://www.dropbox.com/s/q8g5l3ssw7zfuw3/osdteletext.log?dl=0
- https://www.dropbox.com/s/uzjqqtt0fedb4dv/softhddevice.log?dl=0

Geschrieben von: motorsense am Mittwoch, 14.Juni 2017, 13:42 Uhr
Hallo, hast du auch unter /usr/local/src/patches ein zur VDR Version passendes Patch Verzeichnis mit den Pluginpatches? Hier bauen die beiden Plugins (bei softhddevice der VPP branch) ohne Probleme mit 2.3.6 und 2.3.7.
Habe nur das Problem, dass bei 2.3.7 das wechseln von kodi zurück zu VDR Probleme macht (kein Ton mehr). Deswegen bin ich zurück auf 2.3.6.

Gruß

Oli

Geschrieben von: R2D2 am Mittwoch, 14.Juni 2017, 16:14 Uhr
Ich habe keine Probleme mir vdr-2.3.7, es sind halt ein paar Patche für die entsprechenden Plugins notwendig.

Geschrieben von: MegaV0lt am Donnerstag, 15.Juni 2017, 07:15 Uhr
Ich habe die Plugins ausen dem 2.3.4er Paket. Die müssten doch schon gepatcht sein?

Ich habe momenztan zu wenig Zeit und lasse das wohl erst mal, da es ja keine großen Vorteile bringt, den 2.3.x Zweig zu verwenden

Geschrieben von: R2D2 am Donnerstag, 15.Juni 2017, 07:32 Uhr
Natürlich sind die aus dem "2.3.4er Paket" gepatchet, nur halt für vdr-2.3.4 und nicht für vdr-2.3.7.

Geschrieben von: motorsense am Donnerstag, 15.Juni 2017, 07:48 Uhr
Das buildscript von Gen2VDR setzt beim Pluginupdate die Git, svn und hg Stände zurück und nimmt die Patches aus dem zur VDR Version passenden Patchverzeichnis unter /usr/local/src/patches. Also wenn du beim Bauen das aktualisieren der Plugins ausgewählt hast und kein Patchverzeichnis hast, dann sind deine Plugins nicht gepatcht.

Geschrieben von: R2D2 am Donnerstag, 15.Juni 2017, 07:51 Uhr
Das mag wohl auf das originale G2V Buildscript zutreffen, mein Buildscript macht das nicht. wink.gif

Geschrieben von: motorsense am Donnerstag, 15.Juni 2017, 07:54 Uhr
Laut Signatur hat er aber Gen2VDR installiert. ;-)

Geschrieben von: MegaV0lt am Donnerstag, 15.Juni 2017, 09:32 Uhr
Das mit den Patchen wusste ich nicht. Mir fehlen anscheinend die Patche für OSDTeletext und SoftHDDevice. Wo bekomme ich die für VDR 2.3.7 her?

Geschrieben von: MegaV0lt am Donnerstag, 15.Juni 2017, 11:27 Uhr
Bin mir nicht sicher, ob das überhuapt an einem fehhlenden Patch liegen kann:
CODE
video.c:153:39: schwerwiegender Fehler: libavutil/hwcontext_vdpau.h: Datei oder Verzeichnis nicht gefunden
#include <libavutil/hwcontext_vdpau.h>
                                      ^
Kompilierung beendet.
make[1]: *** [<eingebaut>: video.o] Fehler 1
make[1]: *** Es wird auf noch nicht beendete Prozesse gewartet....

Geschrieben von: R2D2 am Donnerstag, 15.Juni 2017, 12:16 Uhr
Es fehlt der ffmpeg-3.x Patch, bzw. Du verwendest das falsche Repo.

Geschrieben von: MegaV0lt am Donnerstag, 15.Juni 2017, 13:43 Uhr
Wenn ich das richtig nachgeschaut habe, ist es das von rofafor. Welches wäre denn das richtige?
- https://github.com/louisbraun/softhddevice-openglosd/commits/master 11 Monate "alt"
- https://projects.vdr-developer.org/git/vdr-plugin-softhddevice.git/ 19 Monate "alt"
- https://github.com/rofafor/vdr-plugin-softhddevice 10 Wochen "alt"


Geschrieben von: motorsense am Donnerstag, 15.Juni 2017, 13:57 Uhr
Genau, der VPP branch baut hier ohne extra Patches. Nur den in gen2vdr enthaltenen softhddevice Patch habe ich hier drin.

Geschrieben von: R2D2 am Donnerstag, 15.Juni 2017, 14:08 Uhr
QUOTE (MegaV0lt @ Donnerstag, 15.Juni 2017, 13:43 Uhr)
[...] Welches wäre denn das richtige? ...

Teste es doch ganz einfach, welches Dir am besten passt.
Ich verwende keines davon.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)